Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows 8 Release Customer Preview on my laptop. I tried to install Ubuntu on it with Ubuntu Windows installer (I have always used this to install, although that was on Windows 7), it installs and asks to reboot, then immediately Windows 8 boots up.

I do not have the option to choose what OS to boot. How can I boot to Ubuntu? VM is not exactly what I would like to use, but it is an option, however a last resort. Any help?

share|improve this question
up vote 7 down vote accepted

Windows 8 uses a graphical bootloader different to that used in Windows 7 or Vista.

The answer here points out that the wubi maintainers have disabled it on the 12.04 CDs for various reasons, one of which is:

  1. ...
  2. ...
  3. ...
  4. Most significantly, Windows is changing it's boot system with Windows 8, and it's not clear how wubi will work with Windows 8, if at all.

So basically, Windows 8 is too new for the Windows Installer to deal with.

You will probably need to edit the Windows 8 bootloader menu. EasyBCD claims to work for Windows 8 but I haven't tried it.

Wubi also loses a lot of functionality you could get with a regular install if you partitioned correctly.

share|improve this answer
It's got nothing to do with the Windows 8 graphical bootloader (and here I assume you are referring to the Windows Boot Manager, not the bootloader which hasn't changed). This works fine with Wubi. It's got everything to do with the UEFI boot which uses GPT disks. Wubi doesn't work with GPT disks. Any computer with Windows 8 preinstalled uses UEFI, but if you upgrade to Windows 8 and have a MBR disk, Wubi works fine. – bcbc Dec 23 '12 at 2:11
@bcbc has provided other information regarding this at which explains why wubi does not work and also provides link to launchpad so folks can vote it up/mark as affected – geezanansa Apr 20 '13 at 22:43

Wubi doesn't work on UEFI systems that use GPT disks. Every new computer with Windows 8 has a UEFI boot, because that's the only thing that supports secure boot.

Therefore Wubi won't work on any new computer with Windows 8.

It works fine with Windows 8 if you boot with BIOS, so if you upgraded to Windows 8, you likely have a BIOS board and it will work.

There's no practical workaround at this time, other than waiting for a fix from Canonical's Ubuntu installer team. The amount of effort required to switch to a legacy BIOS boot and replacing the GPT disk with a MBR partition table setup would negate the whole point of Wubi: to easily install and remove Ubuntu from Windows (for trial purposes).

Here's the bug report:

share|improve this answer
can i set off the secure boot and if yes, then would wubi installer work fine?? – Mandeep Singh Dec 4 '12 at 14:36
No, even if you set off secure boot, it's still booting in UEFI mode and the disk is still partitioned with a GUID partition table, which is not currently supported by Wubi. – bcbc Dec 4 '12 at 18:06
ok..thanks for the help – Mandeep Singh Dec 5 '12 at 9:27

This is an issue that I believe to have solved- it is like this problem here - Dual Boot Windows 8 with Ubuntu 12.10

My suggestion (and it's only a suggestion) is to tpe "msconfig" (without the quotes) on the Windows 8 start screen. In the boot tab, see if Ubuntu is listed. If it is, select the entry by highlighting it and click on "Set as default". This should hopefully load the Ubuntu bootloader instead of Windows' boot menu allowing you you boot into Ubuntu.

Also, from the start screen type in "uefi" and in the settings option on the seach charm, click on "Advanced start up options", click on it. Scroll down to the bottom of the entry and under "Advanced start up", click Restart now. You should now have an option to change the boot order.

I know it is the same solution to another one but to me the core problem is the same- Windows 8 bootloader

share|improve this answer

protected by Braiam Feb 5 '14 at 22:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.