Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just finished assembling my PC and I'm trying to install Ubuntu on it (there is no operating system on this machine). I downloaded Unetbootin on my Mac, downloaded the .iso image, and ran Unetbootin to put it on my flash drive. I plugged it in and ran into a lot of problems which I'd like help/an explanation for?

1- First time i tried to boot from my flash drive I got a Unetbootin default lop which would start up every 10 seconds. I redownloaded Ubuntu and plugged in my flash drive again. Ubuntu started to install.

2- I got a " Apt configuration problem. An attempt to configure apt to install additional packages from the CD failed"message during the middle of it. I clicked okay and then Ubuntu said it was done installing and rebooted.

3- When I rebooted I got a black screen with a blinking cursor. I realized I left the usb drive in the computer so i removed and rebooted.

4- Black screen of death again. Rebooted went to bios, changed the boot order so it booted from the hard drive since I assumed Ubuntu had installed already.

5- Didn't work, rebooted a few times. The I came to a black screen prompting me to put in grub commands which is the stage I'm at now. I tried to type boot but it said there is no loaded kernel?

Please help! I'm really close to finishing off my first build and this is really alarming.

Edit: Hardware I'm using

  • ASRock 970 Extreme3 motherboard
    • AMD Athlon II x3 450 CPU
    • WD5003ABYX 500GB 7200 RPM 64MB Cache SATA 3.0Gb/s 3.5" HD
    • PNY VCGGT4301XPB GeForce GT 430 (Fermi) 1GB 128-bit DDR3 PCI Express 2.0 x16 video card
    • G.SKILL Ripjaws Series 4GB (2 x 2GB) Desktop Memory Model F3-12800CL9D-4GBRL
share|improve this question

2 Answers 2

up vote 1 down vote accepted

While installing Ubuntu from a USB is much faster than from CD/DVD, you also need the OS installer to work correctly with the absence (or presence) of the optical drive (CD/DVD) during install. The installer can sometimes still thinks it is really on a CD drive, and gets confused.

I would suggest simply burning the .ISO image to a CD, and trying this instead.

(OR, get a friend to create a genuine (Ubuntu-native) 'USB installer' on their copy of Ubuntu.)

share|improve this answer
    
Thanks, I will try this tomorrow and see if I'm able to install it properly. In the meanwhile, is it okay for me to be trying ubuntu without installing? It seems to be working okay... –  Laureen Jul 27 '12 at 0:20
    
Should not be a problem. But remember that all files you download or create in this environment disappear after a reboot (unless you save them somewhere, or you installed ubuntu on 'persistent mode' on the thumb drive) –  josinalvo Jul 27 '12 at 0:42
    
Thank you for your suggestion; burning a CD and installing it that way worked without any problems! –  Laureen Jul 29 '12 at 2:30

Odd behaviour such as things failing that should never fail or things that fail once and don't fail the next time you try them are often a sign of bad memory (RAM). The mechanism at work producing such behaviour is that a RAM module stores value "A" in a memory cell but then returns "B" when asked for the value. This can produce data corruption, literally anywhere on the system, since different things use the bad cells at different times. Obviously there are other things that could cause that such as bad installation media or bad media you install to, but that happens much more rarely in my experience.

In your case APT failed when it shouldn't have. Once booting led you to a blinking cursor, next time it lead you to a GRUB error. These happenings should be enough to warrant a memory test. On top of that, memory modules that are faster than standard also known as overclocked or "OC", often have higher rate of defects. That's due to rough grained binning process used to minimize cost. This means that only a few modules per batch (1000 units for example) are tested to sustain the lowered latencies at the high frequencies they are set to operate on. Your modules are such and that should double warrant a memory test.

Memory test is performed by using the Memtest86+ utility, which is available on the default Ubuntu Live USB/CD. The option is in the boot menu and it's called "Memory test". Once you boot from the key and select "Memory test" you will be greeted with blue screen with lots of numbers and bars. The important one is "Pass". You have to let the test run until one full pass is completed. If the pass is completed without anything red appearing in the bottom half of the screen then you are good. The red lines indicate errors. If there are errors, the "Errors" counter will obviously be flipped as well.

Bad RAM is actually the easy way out of this, because the solution is as easy as swapping the modules. Most retailers or manufacturers will swap bad RAM without asking questions. They know. However if your RAM is good, then diagnosing the problem can become much harder.

share|improve this answer
    
I got Ubuntu to load by rebooting, going straight to the boot menu and selecting try Ubuntu without installing. I'm trying to run the memtest86+ from my usb but there is no usb key listed under devices for me to put memtest86+ on. Do you recommend trying on a different computer? Also, I was wondering if it was worth it to just try clicking the Install Ubuntu icon on the desktop? Or will that lead me to the same problem I had before with GRUB? –  Laureen Jul 26 '12 at 23:17
    
Judging your hardware config, all looks fine except the RAM. G.SKILL is known for having more defective modules on the market than say Kingston. So at this point I would strongly recommend to do one pass of Memtest. If you can't boot it off a USB key, try a CD. –  lightrush Jul 27 '12 at 3:03
    
Laureen,just to clarify, Memtest86+ is already on the Ubuntu live USB. It's called "Memory test" in the boot menu. Also your machine seems to be experiencing random behaviour, things that should never happen - APT error during install, once a blinking cursor, next time GRUB error. Such behaviour is usually caused by bad RAM. This means some portion of some of a module writes "A" but then reads "B" when asked. That results in all sorts of data corruption often leading to such random errors. If this is the case - the solution is easy - just ask for RAM replacement. –  lightrush Jul 27 '12 at 14:59
    
Thank you so, so much for the detailed answer! I tried running the memory test from the boot up menu, but it said it couldn't due to an old kernel. At this point, I'm going to burn a CD and perform Memtest86 before I try to install anything, and hopefully it will work this time. I hope it's something as easy as the RAM being faulty. –  Laureen Jul 28 '12 at 4:17
    
I ran Memtest for 8+ hours, and no errors showed up after 9 passes. I installed from a cd and it worked. Thanks for telling me to run it, it's good to know my RAM is good and it was just issues with a USB installation. –  Laureen Jul 29 '12 at 2:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.