Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have followed this tutorial on how to make a .deb package from source(tar.gz) and at the final build command dpkg-buildpackage -rfakeroot

However I get this error at the bottom:

make[2]: Entering directory '/home/user/packages/tympanus/tympanus-1.0.1/src'
make[2]: Nothing to be done for 'check'.
make[2]: Leaving directory '/home/user/packages/tympanus/tympanus-1.0.1/src'
Making check in po
make[2]: Entering directory '/home/user/packages/tympanus/tympanus-1.0.1/po'
INTLTOOL_EXTRACT=/usr/bin/intltool-extract srcdir=. /usr/bin/intltool-update --gettext-package tympanus --pot
rm -f missing notexist
srcdir=. /usr/bin/intltool-update -m
The following files contain translations and are currently not in use. Please
consider adding these to the POTFILES.in file, located in the po/ directory.

src/tympanus.ui

If some of these files are left out on purpose then please add them to
POTFILES.skip instead of POTFILES.in. A file 'missing' containing this list
of left out files has been written in the current directory.
if [ -r missing -o -r notexist ]; then \
      exit 1; \
    fi
make[2]: *** [check] Error 1
make[2]: Leaving directory '/home/user/packages/tympanus/tympanus-1.0.1/po'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory '/home/user/packages/tympanus/tympanus-1.0.1'
dh_auto_test: make -j1 check returned exit code 2
make: *** [build] Error 29
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Help is GREATLY appreciated!I need to fix this issue as fast as possible..

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted
+50

To clarify; add src/tympanis.ui to POTFILES.in.

share|improve this answer
    
Idid that before and I get another error.... –  Nickolas Jul 28 '12 at 20:32
    
Try adding to POTFILES.skip? –  whiskers75 Jul 28 '12 at 20:36
    
It was my mistake..i copy/pasted the .ui file to the /po directory . I edited the POTFILES.in file and it works now :) –  Nickolas Jul 28 '12 at 20:39
add comment

I think the error is pretty clear about what you need to do there. :)

If you run make check in your source tree, when building outside of trying to package a .deb, you should get the same error.

share|improve this answer
3  
-1 your answer is not even a answer, you just say "its pretty clear" nothing more. –  Nickolas Jul 28 '12 at 19:39
    
Read the error message. –  dobey Jul 29 '12 at 13:48
    
More appropriately, my answer is in the question itself, as you pasted it there; and I wrote that error message, as a maintainer/author of intltool. :) –  dobey Jul 29 '12 at 13:51
    
Good to hear you are the maintainer but still it would be much better to tell me what to do, as I was asking for an answer and not a comment :) –  Nickolas Jul 29 '12 at 18:06
    
I gave you the answer. You pasted it in your your question, so I don't see much point in simply duplicating that in an answer. Giving a bounty for a comment isn't great either, which exactly what you did. –  dobey Jul 30 '12 at 13:01
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.