Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Dell Latitude E6530. The keyboard has a SysRq key (Fn+Home). However the magic keys (especially the famous REISUB) doesn't work.

SysRq is enabled in /proc/sys/kernel/sysrq (I get 1 if I cat this file). It works from external USB keybord.

How can I have the Alt+SysRq+REISUB (in fact, Alt+Fn+Home+REISUB) reboot my system?

share|improve this question
up vote 5 down vote accepted

The Dell E6420 works as follows

  • Press/hold both Fn and Alt
  • Press/hold Home/Sysrq
  • Release Fn
  • Press key (tested with T)
share|improve this answer
I realized that in step 3, you can release Fn OR bot Fn and Home/SysRq. Anyway this works on on the 6530 as well. – Calimo Sep 14 '13 at 10:18
how many hands do you need to perform this ? ;-) – solsTiCe Jun 21 '15 at 21:15

The documentation (/usr/src/linux*/Documentation/sysrq.txt) says this:

On x86   - You press the key combo 'ALT-SysRq-<command key>'. Note - Some
           keyboards may not have a key labeled 'SysRq'. The 'SysRq' key is
           also known as the 'Print Screen' key. Also some keyboards cannot
           handle so many keys being pressed at the same time, so you might
           have better luck with "press Alt", "press SysRq", "release SysRq",
           "press <command key>", release everything.
share|improve this answer
It's interesting to know it may be too much keys pressed at the same time, especially since I need to press <kbd>Fn</kbd> too. I tried releasing <kdb>SysRq</kbd> before pressing the command, to no avail. I also tested all the combinations with or without <kbd>Fn</kbd>, with <kbd>Home (SysRq)</kbd>, <kbd>End (PrntScrn)</kbd> and others, but none worked. – Calimo Jul 27 '12 at 17:08
I tried plugging an external keybord, and that one works (I'll edit my question to mention this fact). – Calimo Jul 27 '12 at 17:09
Worked for me, the variant with releasing sysrq – majkinetor May 2 '13 at 11:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.