Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Civilization 5 retail version with an update pack called update 7 via WINE and while the game runs well I am unable to get any sound working.

I am running 12.04 and version 1.4 of WINE via APT.

Any suggestions on how I could get sound working?

share|improve this question
    
It would help to know the version of the game (Steam, etc.) and the version of wine you're using, latest is not specific enough, it really depends on your repo configuration. –  netcoder Jul 26 '12 at 15:23
    
Did you install d3dx90_36 with winetricks? Check out Civilization 5 on WineHQ. –  netcoder Jul 26 '12 at 15:28
    
Yes it was pre installed –  mark kirby Jul 26 '12 at 15:31
    
@markkirby I see you have had no luck with this question, did you ever get it working. I answered a similar question today the answer may help you, check it out askubuntu.com/questions/173994/no-sound-on-wolfenstien-et/…. Let me know if it works and i will add it as an answer. –  Stephen Myall Aug 10 '12 at 17:31
    
Thank you I will check it out –  mark kirby Aug 10 '12 at 17:35
add comment

2 Answers

On appdb, there was an entry for Civ5 with a wine 1.4

http://appdb.winehq.org/objectManager.php?sClass=version&iId=21492&iTestingId=69848

There, the user said:

Works perfect, needed to kill pulseaudio to make sound work.

Give it a try =P

share|improve this answer
    
as to how you can kill/prevent pulseaudio from working, well ... askubuntu.com/questions/8425/… –  josinalvo Jul 29 '12 at 20:54
    
Thanks for the answer but this did not help. –  mark kirby Aug 2 '12 at 11:45
    
did you follow the link to the ways to kill pulse ? One should note that pulse auto-respawns, so a simple killall -9 pulseaudio is not enough –  josinalvo Aug 4 '12 at 14:37
add comment

I am no expert on Wine, but the following solution has helped a number of people with sound problems on wine (it does work for 64bit too).

Marvin Mallari posted to Ubuntu 15 hours ago - For people having sound problems with Wine (like sound is garbled, static, non existant) in Ubuntu 12.04 (w/ Unity and Pulse/ALSA) i found a solution. Go to Synaptic Package Manager, install "ia32-libs-multiarch", it will ask to modify or install other packages, install all packages and restart (not log out then log in) Wine should now play audio perfectly and stable. note: i did this on a 32bit comp, for 64bit, there is probably a different package or maybe the package will work because it says "multiarch" i will try on my 64bit machine later. PS i don't have an account on any Wine or Ubuntu fourms so if someone can please share this somewhere that needs it that would be much appreciated!

Marvin Mallari - Ia32 probably isn't the solution but when I read the addition packages synaptic modifies and installs, a couple of them are for pulse so it is probably those packages that fixed it but in any case ia32 installed whatever it needed to work. It also seems like pulse cpu usage has dropped.

share|improve this answer
    
This did not work either im afraid im starting to think this is a lost cause but will leave the bounty open if people still want to try Thanks for your answer –  mark kirby Aug 2 '12 at 11:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.