Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu 12.04 is missing Hibernate option so after searching a little on Google I came to know that this can solve my problem

sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Fill it with this

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Here is the link : How to enable hibernation in 12.04?

After doing this I restarted my system. when the system booted it hanged ike anything No mouse movement no terminal no nothing. I waited for more than 1 hour Hibernate option appeared but i was not able to use my system anymore. any ideas ?

share|improve this question
1  
Why did you tag it with playonlinux? –  Philippe Aug 1 '12 at 5:31
    
I didnt found any other suitable tag. –  Hussain Nagri Aug 1 '12 at 6:15
1  
Please tag your content suitably. hibernate is a valid tag, as well as power-management, both of which existed well before this post was created. –  hexafraction Aug 2 '12 at 12:28
    
Check this question too. askubuntu.com/q/196364/61218 –  Anwar Shah Nov 18 '13 at 15:08
add comment

2 Answers 2

In this site are a very good how-to.

http://www.howtogeek.com/113923/how-to-re-enable-hibernate-in-ubuntu-12.04/

Sorry for my bad english, but i speak spanish.

share|improve this answer
1  
Now I have a hibernate option in the power tab but it just turns off my system like Shutdown. and when I restart my system it is a fresh new session. No resume of my work. –  Hussain Nagri Jul 27 '12 at 8:30
    
@HussainNagri in this post, there is an instruction to test whether hibernation works on your machine before enabling it. That test is sudo pm-hibernate. Did you run that test to see if hibernate works on your system or not? –  Thomas W. Aug 2 '12 at 13:14
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  hexafraction Aug 14 '12 at 17:36
add comment

One possible cause of being unable to hibernate is if you encrypted your home directory (and with it your swap partition).

share|improve this answer
2  
"Just a thought" is not equal to an answer. –  hexafraction Aug 1 '12 at 15:02
    
Comments are used to "ask authors about clarifications of the post." Please be obsessive with your own comments too. But, to clarify, every answer is the product of a thought. –  Philippe Aug 2 '12 at 6:09
1  
Comments are also used to give extra ideas and half-answers. Please revise your answer to actually specify to decrypt the home directory, including all necessary command so that the OP may understand them. –  hexafraction Aug 2 '12 at 12:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.