Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed and used Ubuntu in several computers. But now I have a problem that I don't know how to solve.

I have a Vaio (Product name: vpcz13c5e), it has a SSD 128gb. I decided to install Ubuntu (12.04, but I have tried older versions as well). Firstly, I tested with live USB, and everything was fine, so I decided go for the complete installation. Then everything went as follows:

  • I chose to use the whole disk (first option, formatting everything).
  • I got a message

    Executing 'grub-install' /deb/sdb failed. This is a fatal error

  • After clicking ok I got another window with 3 options:

    • the first offers different devices to install the bootloader on (I tried all of them and none works).
    • Second option: Continue without a bootloader. In that case I got

      You will need to manually install a bootloader in order to start Ubuntu

    • The third option is Cancel the installation.

So, I chose Continue without a bootloader.

Then I restart the computer (with the Live cd) and in a terminal type sudo fdisk -l but I obtain

fdisk: unable to seek on /dev/sda: Invalid argument

What can I do? any help will be appreciated.

share|improve this question
Are you installing from CD? If you are have you done an MD5SUM on the ISO file? – Mitch Jul 26 '12 at 12:58
I am installing from usb, yes the md5sum is correct. In fact I have tried several versions of Ubuntu and LM. – Alberto Jul 26 '12 at 13:03
Do you have AHCI enabled in the BIOS? Are you using EUFI? – Mitch Jul 26 '12 at 13:05
How can I enable AHCI in the BIOS? I have not that option (my BIOS is InsydeH20 rev 3.5 – Alberto Jul 26 '12 at 13:12

I am experiencing exactly the same problems, but I can get grub working by using boot repair

Although GRUB now works I still can not boot up. I have not tried the advanced options yet. Although if the repair did not succeed, there is a summary of your system with an URL that can be used to help diagnose the problem.

share|improve this answer
Welcome to Ask Ubuntu! This seems like it is, at least in part, an answer to the question, but it's worded as though you're asking a separate, related question. To make this clearer for people searching for help (so they know this post might help them), and to decrease the likelihood that this post will be considered not-an-answer and deleted, I recommend rewording this, and also removing anything that is actually a question (rather than a proposed solution) and posting it as a new question. – Eliah Kagan Aug 3 '12 at 18:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.