Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The banshee 2.41 rejected my mp3 sync with error: “The mp3 format is not supported by the device”

My device is an Iphone 3G

share|improve this question

2 Answers 2

If you have not yet synced your iPhone with a computer running iTunes, you will need to do so first, before Banshee can properly sync to your iPhone.

share|improve this answer
    
Device has already been synced many times with iTunes through the VirtualBox. I have fixed the issues with “usbmuxd” terminal command as root before connecting the iPhone. –  ronline Jul 26 '12 at 12:25

if you can it, would be good if you could add the device in question to your question so we can help you better solve this (And also the version of Ubuntu you are using).

In some cases, the problem is that, since the MP3 format is a closed, proprietary format, then you need to first install the ubuntu restricted extras to have the ability to work/play with mp3 files.

Something along the lines of:

sudo apt-get install ubuntu-restricted-extras or open the Software Center and look for Ubuntu resctrited. This is a meta package which installs other proprietary packages, one of them is the mp3 format support.

share|improve this answer
    
Hi Luis. The ubuntu is 12.04 and Iphone is the 3G. As I have mentioned in my comment to Aaron, the “usbmuxd” terminal command as root before connecting the iPhone solve the issue. –  ronline Jul 26 '12 at 16:50
    
Hi ronline. Can you put that as an answer so it helps future user. –  Luis Jul 26 '12 at 18:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.