Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I suspended my computer when I left work. This morning I turned it on and the resolution was messed up. At first I could only get it to work in 640x480 and all text was unreadable. Since then I have managed to get it to 1280x1024 but nothing beyond that and certainly no second monitor.

I have a Dell Precision m4600. It has an nvidia quadro 1000m graphics card.

It seems that at the very least my xorg.conf was messed up by something as it was empty. I suspect an update but I didn't pay much attention to what updates were installed yesterday so I can't be sure.

I have tried (almost but not exactly in order):

restoring xorg.conf from some backed up versions...unfortunately these were incorrect as well which is probably why they weren't active in the first place. Didn't work anyway.

running nvidia-config

removing all nvidia drivers

running dpkg -reconfigure xserver-xorg

reinstalling latest nvidia drivers

removing xorg.conf entirely

and probably some permutation of all the above steps combined with multiple reboots and repressing the urge to smash my laptop against the wall give up on technology and move to a sandy beach in the mediteranean area. Ok, maybe I am slightly frustrated.

I understand there are a lot of problems with nvidia drivers and the latest ubuntu. Nothign I do seems to convince it there even are nvidia drivers installed.

I haven't found an answer in other threads but it is a bit difficult searching when resolution is less than ideal. If there is answer in another thread please point me there. Otherwise please prove you brilliance (or my stupidity) by giving the magic one liner which solves all my problems. please?

share|improve this question
    
Ok, this is a partial solution but by no means a complete solution nvidia-uninstall apt-get --reinstall install libgl1-mesa-glx I at least get a resolution of 1920x1080...but no multiple screens and it also seems I can only use this resolution. This is really making it difficult to work. My alternative is to install windows and I don't want to do that. –  Jasper Floor Jul 26 '12 at 9:45
    
then I tried to reinstall and reconfigure x and I'm back to 1280x1024. I'm depairing of getting any work done today. –  Jasper Floor Jul 26 '12 at 9:59
add comment

1 Answer

After all that I finally found out I had Optimus enabled in the bios. Disabling that fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.