Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 12.04, how do I disable or change the Alt+` shortcut which lets you switch between multiple windows of a single application? (see below for Terminal example)

My Windows VM in Korean needs to use that keyboard combination to switch character sets.

enter image description here

share|improve this question
    
You can refer this askubuntu.com/questions/122209/… , and to MODs possible duplicate. –  tijybba Jul 26 '12 at 7:09
    
askubuntu.com/a/169836/50523 –  trent Jul 31 '12 at 5:55
add comment

3 Answers

Why not change the shortcut in Windows? Mine defaults to Left Alt+Shift to switch keyboard languages. Control Panel > Region and Language > Keyboards and Languages tab > Change keyboards button > Advanced Key Settings tab > select Between input languages (the current key is shown on the right side) > click the Change Key Sequence button to change the shortcut that Windows uses

share|improve this answer
add comment

This appears to be a bug in Compiz (Unity's window manager), in that the Alt+` shortcuts should appear in its shortcut list, but instead they show as disabled.

To disable (or change) the Alt+` and Alt+Shift+` to switch between multiple windows of one application:

  1. Click here to install the Compiz Settings Manager (CCSM) using the Software Center

    • Or install it from the terminal with sudo apt-get install compizconfig-settings-manager from the terminal
  2. Start it from the Dash or by typing ccsm from the terminal.

    Statutory Warning: Compiz Config Settings Manager is an advanced tool and one tiny mistake, typo or an accidental click of the mouse can leave your desktop unusable, requiring time and effort to fix it. Please be very careful and follow instructions...thanks. If you mess up, please see this answer on how to fix things.

  3. Type "Unity" in the filter box on the left, and click on the Ubuntu Unity Plugin:

    enter image description here

  4. Click on the Switcher Tab on top, and

    enter image description here

    • Look for the Key to flip through windows in the switcher entry near the bottom (scroll down if necessary)
    • Click on the Disabled button next to it
    • Check the Enabled box on the "Edit Key" popup
    • The keys will show, and click on the Grab key combination button
    • Press any keyboard shortcut combination (it doesn't matter, unless you want to remap this behavior to another shortcut); this will appear beneath the box.
    • Click on OK, and this shortcut will now show in place of the Disabled button
    • Now click this button again, uncheck the Enabled box, and click on OK so that the shortcut again shows Disabled.

The Alt+` is now disabled. To also disable the reverse Alt+Shift+` shortcut, repeat step 4 for the Key to flip through windows in the switcher entry.

Finally, close CCSM and if you no longer need it, please consider uninstalling it.

share|improve this answer
add comment

Open the system settings, go down to hardware and click keyboard then choose the shortcuts tab.

Here you can modify the shortcuts all you want hope that helps.

share|improve this answer
    
Thank you both for your responses. Unfortunately, that thread is for modifying the HUD (which is just the ALT key by itself). I couldnt locate ALT+` in the hardware>keyboard>shortcuts location. My problem is the ALT + ` (this combination of keys defaults to the same behavior as ALT + TAB so I dont need it. I need ALT + ` to type in Korean when i switch my keyboard. How can I disable "ALT + `(the key next to 1 on the keyboard)"? Thanks sooo much. –  Albert Francis Lavietta Jul 26 '12 at 22:16
    
Does anyone know? –  Albert Francis Lavietta Jul 29 '12 at 23:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.