Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 12.04 on an AMD athlon II x2 240 w/ 3 GB ram and an ATI Radeon HD5670. I'm having the problem of sudden slowdowns, which I think may be due to the graphics driver. I'm an Ubuntu newbie and would love some basic instructions or explanations.

I've tried the fglrx driver and the driver from the ATI website but they both produced slowdowns. And checking the Details under System Settings, it showed the VESA-REDWOOD driver. So I tried purging the fglrx driver like on this link How do I restore default video drivers? but then I can't see anything when Ubuntu boots up, even with the nomodeset option, I was able to fix it before with the nomodeset but now nothing.

I'm confused with w/c driver I should really install, should I go with the fglrx or the ATI driver, and what are open source drivers? Is there a way to remove all of these and start fresh? A nice explanation or link to a guide explaning all of this stuff would be helpful. Thanks a lot!

share|improve this question
I am experiencing a very similar problem on my comp. I think I have the same CPU, but I have an ATI 6670. I ran Ubuntu 12.04 on the (almost) exact same comp when it came out, but lightning hit my Mobo and I bought a new one and now I cannot get ubuntu to run even from the livecd. I don't have an alternate OS (writing this from my wife's apple). Are you seeing weird lines down the screen? – user82780 Aug 11 '12 at 19:32
Yup, I see horizontal lines and screen flickering. I suggest you use the 'fglrx' driver instead. On the grub menu, just add the 'nomodeset' option when booting(choose ubuntu from grub, hit 'e' and add 'nomodeset' option and press 'ctrl+x'), and you can succesfully boot into Ubuntu. Then you can install the 'fglrx' drivers through the additional drivers option. Good luck! – mumble Aug 11 '12 at 19:49
up vote 0 down vote accepted

It seems like my problem is the same as this, Can't install fglrx or boot computer. I ran the command, /usr/share/ati/ --force on the recovery console to completely remove fglrx. Then I was able to login (using nomodeset on grub) and download the latest ATI driver from the AMD website.

And everything works again, but I still get graphic glitches every now and then, lines running across the screen. It's completely tolerable but I hope someone finds a fix for this. It's also showing the VESA-REDWOOD driver under System Settings > Details.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.