Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I lost compiz zoom due to some incompatibility that I am not sure about. I read about a fix before, but I forgot what it is. When I try to zoom with the super key and mouse it just vibrates the cursor.

After further testing to find the problem, I know it has to be something that is trying to put the pointer to the centre of the screen. Hopefully someone will be able to track down the cause, because so far I cannot.

EDIT - I've tried all kinds of options, including resetting all the settings on the plugin, still no change. I can't zoom, even if I change the keys. If it helps, restraining the mouse to the zoom area makes it jump to one side of the screen.

Could it be that I have dual outputs that is causing the problem?

share|improve this question
2  
Your mouse vibrates? –  Marco Ceppi Dec 10 '10 at 3:16
    
so said so done =D –  RolandiXor Dec 10 '10 at 3:31
    
the cursor I should say –  RolandiXor Dec 10 '10 at 3:31
    
Try to reset it to default settings(gconftool-2 --recursive-unset /apps/compiz).Restart your ubuntu system and try again. –  karthick87 Dec 10 '10 at 12:40
    
I'm quite sure there was an application or plugin blocking it :(.. I just wish someone knew which one. –  RolandiXor Dec 10 '10 at 14:59
add comment

2 Answers

up vote 1 down vote accepted

This is caused by a bug when using dual monitors. As far as I know the only current fix is to unplug a monitor. You may be able to get it working by editing the General options in ccsm to not autodetect outputs and instead manually specify your monitors' sizes and positions.

share|improve this answer
    
I had fixed the problem before (forgot how I did it), but this is a method that works, so I'll accept it. –  RolandiXor Mar 5 '11 at 15:31
add comment

If you're also using the desktop cube, make sure you have "multiple cubes" selected in the desktop cubes "Multi Output Mode" list.

share|improve this answer
1  
I'm using Unity, and I since found out what the problem is, it is Nvidia's TwinView. –  RolandiXor Mar 14 '12 at 4:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.