Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This evening I was attempting to disable the guest account and something went awry.

Currently on boot Ubuntu enters low graphics mode. No specific error report.

What did I do? Before this error occurred I added a line of code in lightdm.conf to disable the guest account. I think I may have accidentally erased the contents of lightdm.conf. Not entirely sure.

I troubleshooted for the past hour using various suggestions from other Questions to no avail.

share|improve this question

closed as too localized by Bruno Pereira Jan 31 '13 at 12:55

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Please add the contents of your lightdm.conf to your question. –  Jorge Castro Jul 26 '12 at 2:19
    
I assume you meant low graphics mode? –  mfisch Jul 26 '12 at 2:21
    
Yes I meant low graphics mode. My mistake. As for the contents. How would I check that? I am not able to access the desktop. The most I am able to do from the Ubuntu partition is access the terminal through ctrl+alt+f1 from the low graphics menu. –  user79318 Jul 26 '12 at 2:25
    
I guess you'd have to type in the contents from another PC, not very practical unless you can copy the files to another system. I'd also love to have a look at your log file, /var/log/lightdm.log. If you want a short-cut, just use type in the conf file I posted below. –  mfisch Jul 26 '12 at 2:37
add comment

2 Answers 2

There is an example version of lightdm.conf at:

/usr/share/doc/lightdm/lightdm.conf.gz

You can see it with zcat /usr/share/doc/lightdm/lightdm.conf.gz.

share|improve this answer
add comment

We can't do much debugging without your lightdm.conf file, but if you want a minimal version that will work, try this one:

[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter
allow-guest=false

EDIT: For future reference, you can make many changes to lightdm.conf easily and safely with the tool /usr/lib/lightdm/lightdm-set-defaults, including disabling the guest session.

Try it next time. Run it without any arguments to see all the options. /usr/lib/lightdm/lightdm-set-defaults -l false will disable the guest account.

share|improve this answer
    
The file was similar before I edited it. I currently cannot access the desktop. How would I go about editing the file from low graphics mode? –  user79318 Jul 26 '12 at 2:36
    
Control-Alt-F1 to drop to a virtual terminal. Login, then sudo vi /etc/lightdm/lightdm.conf –  mfisch Jul 26 '12 at 2:40
    
So did it work? –  mfisch Jul 26 '12 at 2:49
    
I'll have a go at it tomorrow, getting late. Deliver an update then. Thanks for the advice –  user79318 Jul 26 '12 at 2:49
1  
@user79318 vi may be difficult for novices, so I recommend you use sudo nano. Ctrl+O(the letter, not the number) followed by Enter(twice, I think) saves, and Ctrl+X exits. –  hexafraction Jul 26 '12 at 14:24
show 2 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.