Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think I have accidentally done something rather stupid. Again. I ran compiz --replace in a terminal, and I think I did something screwy to unity, because the bar at the top and the launcher is missing. I think I could live with it if:

a.) I knew how to open the home folder from the terminal;

and

b.) I knew how to open CCSM (Compiz Config Settings Manager) from the terminal;

but some repair for unity would be useful. I have tried sudo apt-get update && sudo apt-get upgrade, and this: http://www.tuxgarage.com/2011/04/missing-top-and-side-panels-in-unity.html, and nothing has worked.

share|improve this question
    
None of this is really working, I have managed to install (and defect to) a GNOME environment, but is there anything else that could work? –  Selby Rowley-Cannon Jul 26 '12 at 10:15
    
possible duplicate of Unity doesn't load, no Launcher, no Dash appears –  jokerdino Oct 1 '12 at 4:24
    
I have the same problem. Changed compiz configurations and now the system tray doesn't appear. It is a valid question. –  neves May 21 '13 at 12:11
add comment

closed as too localized by Jorge Castro, hexafraction, jokerdino, Mitch, Anwar Shah Oct 1 '12 at 17:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

The best solution is to log out and back in. If your top bar is missing you might have a hard time logging out, so here are a few ways that may work:

  1. First, try pressing Alt+F2 to see if you get a text box where you can enter commands. If you do, type /usr/lib/indicator-session/gtk-logout-helper. That logs out the same way as selecting the Log Out option from the indicator-session menu in the top panel.

  2. Alt+F2 doesn't do anything, try opening a terminal with Ctrl+Alt+T (or use a Terminal that's already open, if there is one). Then enter the /usr/lib/indicator-session/gtk-logout-helper command there.

  3. If neither of those ways work, switch to a text-based virtual console (Ctrl+Alt+F1), log in (don't worry that nothing seems to be happening as you're entering your password), and run:

    pkill -u yourusername

    Replace yourusername with your actual username, or replace it with $USER which will expand to your username.

    Then switch back to the GUI with Alt+F7, and you can log in.

  4. If you're an administrator on this machine (and thus can run commands as root with sudo), then rather than forcing a logout by terminating all the processes that belong to you, you might prefer to terminate the graphical session by stopping and restarting the display manager:

    sudo stop lightdm
    sudo start lightdm
    

    Then press Alt+F7 to return to the graphical login screen. (If you want to log out of the virtual console first, you can do so with the exit or logout command.)

share|improve this answer
add comment

Open the File manager from the Terminal: type nautilus

Open CCSM: type ccsm

The commands apt-get updateand apt-get upgrade do not fix anything at all, they update your repositories to check if newer software is available and then upgrade whatever software you have, respectively.

To reset Unity type unity --reset

share|improve this answer
add comment

Type the following in terminal ( What is the terminal? ) with internet connection on. One line at a time, hit enter after each line.

sudo apt-get update

sudo apt-get install --reinstall unity
share|improve this answer
add comment

use metacity --replace

or just log out and log back in

you can open ccsm from the terminal with ccsm &

to get back to the login screen hit ctrl-alt-f1 then log in and type /etc/init.d/*dm restart

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.