Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to specify a local .iso image of the Ubuntu OS I would like to use to create a virtual machine of. According to vmbuilder kvm ubuntu --help, (and this post) you are allowed to specify an .iso file instead of using a mirror.

I have downloaded my own copy of Ubuntu Desktop 12.04 i386 from and tried to specify it like so

vmbuilder kvm ubuntu --suite=precise --arch=i386 -o --flavour=server --iso=/home/fred/Desktop/ubuntu-12.04-desktop-i386.iso --libvirt=qemu:///system --ip= --gw= --part=vmbuilder.partition --templates=mytemplates --user=fred --name=fred --pass=password --mem=1024 --cpu=1 --hostname=vm1 --bridge=br0

I have tried replacing --flavour=server with --flavour=desktop, --flavour=virtual and nothing at all.

The help command states " --iso=PATH This requires suite and kernel parameter to match what is available on the iso, obviously. " which makes me think I could be getting the --flavour or --suite option wrong though I don't understand how or why.

I ran it with the --debug command and pasted the output on pastebin here. Mainly it's failing to create the image because: Failure trying to run: chroot /tmp/tmp6UfExa mount -t proc proc /proc .

share|improve this question

This could be a very local issue (ie something quirky on your machine). I had a similar issue and it was to do with a type on one of the switches and not a mounting issue at all. But...

If you're running 12.04 yourself you shouldn't need to specif the iso. You have already told the application you want to install the 'precise' suite (ie 12.04) and you should probably --flavour=virtual (that's the joy of vmbuilder - no need to download the iso's if you just want Ubuntu. Try simplifying your command even if it creates an image you late have to delete because it is unusable or not enough memory. You can start with something as simple as

vmbuilder kvm ubuntu

and if you want it 'virsh'-compatible or specify memory etc then yes add the appropriate switch:

vmbuilder kvm ubuntu --suite=precise --mem=1024 --flavour=virtual -o --libvirt qemu:///system --user=admin --pass=myPassw0rd

I also find that despite configuring things in what I believe is the same way, I sometimes find I have to move my image files to a different directory in /var/lib/libvirt.

Add the bridge, --addpkg acpid (if you want to be able to shutdown an ubuntu instance correctly, openssh-server is good too allowing you to access the machine other than via VNC/screen scraping.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.