Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had multiboot windows 7 and ubuntu on my Samsung notebook NP305U1A-A07IN. I uninstalled Ubuntu by deleting all unnamed partitions from windows disk partitions as I read on net somewhere.

Now I guess Ubuntu is gone but i can't boot into windows anymore. Whenever I boot it says

error:  no such partition
grub rescue>

I know my windows partition and data is all there. Something is wrong with boot loader or boot manager.

As I have notebook it doesn't have DVD driver. But I have created USB stick of windows and Ubuntu too. But my BIOS menu can't recognize or load these sticks at all. I tried it on other notebook it works. But not on this one only. I even changed priorities.but it says boot override and shows two options only to boot hdd and network.

I checked a lot of forums and here too. But no solutions so far. I can't boot any USB stick so Windows command prompt solution from recovery is no use.

I have another doubt if these manufacturers lock BIOS to boot from another USB or DVD. But I installed Ubuntu from USB itself and now it can't detect any of those. I don't want to lose any data. Anything will work Windows or Linux now. At least let me know the way I can bring windows installation on it.

share|improve this question
Do you know in which partition your Windows installation resides? It may be possible to chainload Windows from that partition. As you have deleted your Ubuntu partitions the GRUB configuration file grub.cfg has been deleted alongside, which contains the OS menu entries you see on boot. – Samik Jul 25 '12 at 20:24
There's nothing you can do without entering recovery mode. If it doesn't boot from USB, try entering the BIOS, wait a few seconds and "exit without saving changes". I have similar issues on my Samsung laptop and doing this ensures it boots from the USB device (I think it needs a moment before the USB powers up after powering the computer). You may want to try different USB ports as well. – netcoder Jul 25 '12 at 20:56
i tried that.nothing at all.even in bios menu it say N/A in front of USB key,USB HDD.there are only two options hdd and netowrk.i waited for like 3 hours but nothng happened. – PratikG Jul 26 '12 at 14:03
hey worked. i switched off it.then i connected pd containing windows.and restarted it and it worked. thanks alot. – PratikG Jul 26 '12 at 14:09
I open up my start menu then I right click on "my computer" then I go managed. I have deleted some program it which show in the step to remove backtrack. During the step, I have just a blank in my mind. When I m back I have deleted the wrong file. Then I restart, then It come out those word. How to solve it? – user143229 Mar 26 '13 at 0:41

I don't think deleting all unnamed partitions from Windows is the right answer.

You should reinstall your GRUB to restore your boot menu. Check this question, it might be helpful.

share|improve this answer
Thanks for pointing to that answer, but the process mentioned there involves booting from a Live Ubuntu CD (or Live USB), which, the original poster is unable to do. You may want to modify your answer in that perspective. – Samik Jul 26 '12 at 11:56
thanks.but i checked all of thread mentioning my error. no soluions so far. – PratikG Jul 26 '12 at 14:04

Faced this fearsome screen of death after installing 12.04 dual boot. Using 11.04 earlier on. Yeah, the windows stuff were still there. In the end, I solved the problem by installing 10.10 from CD to restore grub. Not touching 12.04 until this issue is stable.

share|improve this answer

You should change your boot priority to USB as first priority. If its not shown, this cannot be done unless you get the boot file from another computer and transfer it to your current one.

share|improve this answer
Welcome to Ask Ubuntu! Can you add to your answer with instructions on how to do that? – Kevin Bowen Jan 14 '13 at 11:31

In my case the hard disks have been configured to work in IDE mode, which worked perfectly in Ubuntu 11.04.

After installing Ubuntu 12.04, I got the "no such partition" error.

I solved it by configuring the BIOS to work with disks in ACPI mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.