Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing VIM using terminal command sudo apt-get install vim but it didn't installed and it showed the following message:

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:  flashplugin-installer   : Breaks: flashplugin-downloader (< 11.1.102.55ubuntu3) but  
11.0.1.152ubuntu1 is to be installed
vim : Depends: vim-common (= 2:7.3.429-2ubuntu2.1) but 2:7.3.429-2ubuntu2 is to be installed  
      Depends: vim-runtime (= 2:7.3.429-2ubuntu2.1) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install'  with no packages (or specify a solution).

Even if I try using apt-get -f to install, it didn't work. Please provide a proper solution for this.

share|improve this question
1  
Did you update the package database? sudo apt-get update; sudo apt-get upgrade –  jmetz Jul 25 '12 at 18:25

3 Answers 3

What I see there is that the flashplugin-installer package had some kind of downloading or installing problem and it is not letting you install vim. What I suggest is remove the flashplugin package, then do a refresh of the repository cache and then download vim. Afterwards just install flash again, although I recommend doing it via the restricted extras. Something like the following:

  1. sudo apt-get remove flashplugin-installer

  2. sudo apt-get update

  3. sudo apt-get install vim

  4. sudo apt-get install ubuntu-restricted-extras

On another note I actually still recommend using aptitude over apt-get. Or even synaptic to solve in an easy matter several conflicting problems between packages.

share|improve this answer

probably answering this too late. but try uninstalling vim-common too. I was facing a similar problem with the error message

The following packages have unmet dependencies:
 vim : Depends: vim-common (= 2:7.3.429-2ubuntu2) but 2:7.3.429-2ubuntu2.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I was able to solve it by uninstalling vim-common package first.

sudo apt-get remove vim-common

After that i was able to install it with no problems.

share|improve this answer
    
Thank you, that helped my problem. –  René Nyffenegger Jan 31 at 22:40

I would like to combine both of ur answers. Type it one by one:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get update
sudo apt-get remove vim-common
sudo apt-get install vim
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.