Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading Ubuntu 11.10 to 12.04 I have lost control of brightness of my Toshiba Satellite L650. Under Ubuntu 11.10 all worked ok.

Now I can change brightness only in terminal using:

echo 3 > /sys/class/backlight/acpi_video0/brightness

I have also folder named /sys/class/backlight/toshiba/ and in it there is file brightness

When I use my keyboard shortcut Fn-F6 and Fn-F7 value in file brightness (from toshiba folder) changes, but brightness in computer not, because it seems to be controlled by value in /acpi_video0/ folder.

I tried to change configuration in grub from this:

GRUB_CMDLINE_LINUX=""

to this:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

But then folder /toshiba/ disappeared, and I can not change brightness even in terminal.

acpi is installed.

Could anyone help me to find solution?

lspci gives following output:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Redwood HDMI Audio [Radeon HD 5000 Series]
02:00.0 Ethernet controller: Atheros Communications Inc. AR8152 v1.1 Fast Ethernet (rev c1)
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
share|improve this question
    
Strange issue . Have a look here –  Web-E Jul 25 '12 at 18:15
    
What if you link /sys/class/backlight/toshiba/brightness to /sys/class/backlight/acpi_video0/brightness? I am not entirely sure if it's going to work, but there is not harm in trying. Remove the acpi_backligh option from Grub first, then reboot, an then run sudo ln -sf /sys/class/backlight/toshiba/brightness /sys/class/backlight/acpi_video0/brightness. Now try the brightness keys. If it works, we can automate the linkage. –  mikewhatever Jul 25 '12 at 19:42
    
As I said I solved this issue by editing xorg.conf. But thanks a lot for answering. –  Marcin Jul 25 '12 at 20:33
    
Can you post your solution as an answer so other people with this laptop can benefit? Thanks! –  Jorge Castro Aug 21 '13 at 22:12
    
@JorgeCastro I've removed the answer from question and posted it as an actual answer. –  Eric Carvalho Aug 21 '13 at 22:15
add comment

1 Answer 1

This is the answer OP posted in the question:

I've just found solution and brightness started to work.

I just change put:

gedit /etc/X11/xorg.conf

and my xorg.conf was very short:

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

So added at the end:

Section "Device"
    Identifier     "ATI Radeon HD 5000M"
    Driver         "radeon"
    Option         "NoLogo" "True"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

And now is ok.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.