Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu comes default with vino-server, I can remote into my machine, and connect to it, however, the display inside my remote client, is a mirror of my own desktop.

I tried using one monitor, thinking that's what is the issue but still won't work.

(vino-server:3608): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed
25/07/2012 12:23:58 PM Autoprobing TCP port in (all) network interface
25/07/2012 12:23:58 PM Listening IPv6://[::]:5900
25/07/2012 12:23:58 PM Listening IPv4://0.0.0.0:5900
25/07/2012 12:23:58 PM Autoprobing selected port 5900
25/07/2012 12:23:58 PM Advertising security type: 'TLS' (18)
25/07/2012 12:23:58 PM Re-binding socket to listen for VNC connections on TCP port 5900 in (all) interface
25/07/2012 12:23:58 PM Listening IPv6://[::]:5900
25/07/2012 12:23:58 PM Listening IPv4://0.0.0.0:5900
25/07/2012 12:23:58 PM Clearing securityTypes
25/07/2012 12:23:58 PM Advertising security type: 'TLS' (18)
25/07/2012 12:23:58 PM Clearing securityTypes
25/07/2012 12:23:58 PM Advertising security type: 'TLS' (18)
25/07/2012 12:23:58 PM Advertising authentication type: 'No Authentication' (1)
25/07/2012 12:23:58 PM Re-binding socket to listen for VNC connections on TCP port 5900 in (all) interface
25/07/2012 12:23:58 PM Listening IPv6://[::]:5900
25/07/2012 12:23:58 PM Listening IPv4://0.0.0.0:5900
25/07/2012 12:23:58 PM Clearing securityTypes
25/07/2012 12:23:58 PM Clearing authTypes
25/07/2012 12:23:58 PM Advertising security type: 'TLS' (18)
25/07/2012 12:23:58 PM Advertising authentication type: 'VNC Authentication' (2)
25/07/2012 12:23:58 PM Clearing securityTypes
25/07/2012 12:23:58 PM Clearing authTypes
25/07/2012 12:23:58 PM Advertising security type: 'TLS' (18)
25/07/2012 12:23:58 PM Advertising authentication type: 'VNC Authentication' (2)
25/07/2012 12:23:58 PM Advertising security type: 'VNC Authentication' (2)

(vino-server:3608): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that     doesn't believe we're it's parent.

(vino-server:3608): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
25/07/2012 12:24:16 PM [IPv4] Got connection from client static-XXXX.bltmmd.fios.verizon.net
25/07/2012 12:24:16 PM   other clients:
25/07/2012 12:24:29 PM Client Protocol Version 3.7
25/07/2012 12:24:29 PM Advertising security type 18
25/07/2012 12:24:29 PM Advertising security type 2
25/07/2012 12:24:30 PM Client returned security type 18
25/07/2012 12:24:30 PM Advertising authentication type 2
25/07/2012 12:24:30 PM Client returned authentication type 2
25/07/2012 12:24:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type     -258
25/07/2012 12:24:37 PM Enabling NewFBSize protocol extension for client static-XXXX.bltmmd.fios.verizon.net
25/07/2012 12:24:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type 1464686185
25/07/2012 12:24:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type -259
25/07/2012 12:24:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type -257

(vino-server:3608): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
25/07/2012 12:24:55 PM Client static-XXXX.bltmmd.fios.verizon.net gone
25/07/2012 12:24:55 PM Statistics:
25/07/2012 12:24:55 PM   key events received 0, pointer events 80
25/07/2012 12:24:55 PM   framebuffer updates 43, rectangles 152, bytes 292401
25/07/2012 12:24:55 PM     tight rectangles 152, bytes 292401
25/07/2012 12:24:55 PM   raw bytes equivalent 11621332, compression ratio 39.744502
25/07/2012 12:25:21 PM [IPv4] Got connection from client static-XXXX.bltmmd.fios.verizon.net
25/07/2012 12:25:21 PM   other clients:
25/07/2012 12:25:28 PM Client Protocol Version 3.7
25/07/2012 12:25:28 PM Advertising security type 18
25/07/2012 12:25:28 PM Advertising security type 2
25/07/2012 12:25:28 PM Client returned security type 18
25/07/2012 12:25:29 PM Advertising authentication type 2
25/07/2012 12:25:29 PM Client returned authentication type 2
25/07/2012 12:25:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type     -258
25/07/2012 12:25:37 PM Enabling NewFBSize protocol extension for client static-XXXX.bltmmd.fios.verizon.net
25/07/2012 12:25:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type 1464686185
25/07/2012 12:25:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type -259
25/07/2012 12:25:37 PM rfbProcessClientNormalMessage: ignoring unknown encoding type -257

(vino-server:3608): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
25/07/2012 12:25:47 PM Client static-XXXX.bltmmd.fios.verizon.net gone
25/07/2012 12:25:47 PM Statistics:
25/07/2012 12:25:47 PM   key events received 0, pointer events 7283
25/07/2012 12:25:47 PM   framebuffer updates 27, rectangles 82, bytes 113354
25/07/2012 12:25:47 PM     tight rectangles 82, bytes 113354
25/07/2012 12:25:47 PM   raw bytes equivalent 5831432, compression ratio 51.444431

couple of things I notice, the following error occurs over and over again. the menu error seems to be caused by ubuntu, similar problems occur http://trac.wxwidgets.org/ticket/14292,

(vino-server:3608): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

the second one also seem to be a display related issue, can't seem to figure out a solution. I really rather try to fix this issue than have to use the other vnc clients most suggest.

(vino-server:3608): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed
share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Here's the solution to my issue. First, I forgot to mention I ran all these commands in SSH. I had setup the server, and by the time I got to school, was trying to run the server via SHH, and that is what caused the issue.

Ran the same commands on my the node itself, and no problem occurred.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.