Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu on both my laptop and my workstation.

  • My laptop is a somewhat older one, with a 2Ghz centrino Core 2 Duo processor, an NVidia GeForce Go 7300 graphics card, and 2 gigabytes of system RAM. Compiz+Emerald works flawless and super fast on this computer in every aspect.

  • My workstation is a dual core (not Core Duo) 2.5GHz system, with a 1GB GeForce 9500GT card and 4 gigabytes of system RAM. 3D performance with Compiz is super slow here though, and other operations feel heavy as well. Opening a new tab in Firefox for example takes a couple of seconds.

Both computers have the same driver version installed (173.14.28).

I am new to this OS, any suggestions on how I could improve performance on my workstation? Many thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

My first question would be which version of Ubuntu did you install. Regardless though, that seems to be a fairly old driver for the 9500gt. If you go to System > Administration > Additional Drivers, you should see that there are 2 choices, one of which is the 173 driver you have. The other one is a much more recent version (260.19.06), at least in the latest Ubuntu version, which is 10.10, it is. You want to activate this version. 173 is meant to maintain support for older cards.

share|improve this answer
    
wow thanks that really solved the problem :) Do you think I should attempt to change the driver on my laptop too? is there any chance it creates a problem if I install the newer driver? –  Spiros Dec 9 '10 at 22:01
    
Generally speaking the newest driver that supports your card is the best driver. –  RAOF Dec 9 '10 at 23:09
    
thnx I will try tp update it. –  Spiros Dec 10 '10 at 8:03

It just so happens my testing video card (An awesome playing card) is the 9500 hehe. Ok if you had 10.04 and changed to 10.10 you WILL notice an improvement in every game. In my case WOW, l4d1, l4d2. Anyway yo be sure you have the latest drivers do the following:

Go in the menu to System > Administration > Additional Drivers and install the one that says RECOMMENDED. It is the one with version 260.

After that reset the PC. Then go to in the menu to System > Administration > Nvidia Settings and change the resolution and any other stuff you want to change. There is an option to change the behaviour from Quality to Performance. I really suggest performance.

If you can not use the menu for some reason or do not understand the above then do the following:

  1. Press ALT+F2 which should open a small command box.
  2. Type jockey-gtk and press enter. it will open the Additional Drivers windows which will show you the Nvidia drivers. just install the one that says Recommended which is the latest for the one you have.
  3. Reboot your PC then ALT+F2 again. This time, type nvidia-settings and press enter.
  4. configure the nvidia-settings. Enjoy the games with full power!

NOTE - You can have both drivers installed and it wont give you problems. Although i recommend to remove the one you have and install the new one.

share|improve this answer
    
Although I don't use it for games, the driver was indeed the problem. Thanks for the useful answer! –  Spiros Dec 10 '10 at 8:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.