Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

OK, I know this has been a problem for a while, and I know by now this really old Pentium II laptop is really really really obsolete. However, I have installed Lubuntu 10.10 on this laptop and things seem to work fine except the sound.

Now I've read and gone through a bunch of tutorials and guides to working around this, none of which have worked. I have gone through this Ubuntu bug report and that doesn't work either.

The problem I think is that the latest workaround is (understandably) about two Ubuntu versions behind. Now I'm not sure what has changed since then to make that workaround not work, but I would appreciate any help.

Thanks

share|improve this question

2 Answers 2

OK... I figured it out. Basically you need to follow the instructions in the above linked Ubuntu bug report pertaining to Ubuntu 9.10. Those need to be followed to every last detail. That is you need to make sure that you initialize the bios AND THEN disable bios quick boot.

You also need to ensure that you are using ALSA. I give credit here to Mr. Brooks for drawing attention to this. He suggested using gstreamer-properties to ensure this. That is what I used. The problem is it isn't installed in Lubuntu 10.10 by default. To get it you need to install the gnome-media package from the repositories. Then alt+f2 and run gstreamer-properties. Under default output, select ALSA as the plugin, and default as the device, then press test. If you've done everything in that order, you should be hearing the sweet sweet sound of victory.

Side Note: Along the way I ended up also installing some gstreamer plugins including the gstreamer alsa plugin. So if the above alone doesn't work, go ahead and install that then try gstreamer properties again (after a reboot). Good Hunting!

share|improve this answer

Did you disable Quick Boot in the BIOS setup? And then Initialize the BIOS. I have a 600E running 10.10 and the sound works fine after completing those 2 steps and then make sure you use the ALSA or OSS driver and not PulseAudio (I use ALSA).

share|improve this answer
    
So do I have to blacklist and add modules, or just do the above? Also, how would I ensure That I'm using alsa in lubuntu? –  user7120 Dec 10 '10 at 0:37
    
I read all of the posts about blacklisting, etc. and none of them worked for me. In fact they made it worse. I changed the sound driver by hitting alt+f2 and then running gstreamer-properties. Select the driver and test. –  Weldon Brooks Dec 10 '10 at 0:49
    
ok... so I removed everything all the black listing and everything else that the above linked bug report mentions. I initialized the bios and disabled quickboot : still no sound. trying to access gstreamer-properties and its nowhere to be found in lubuntu... Are you using Lubuntu? –  user7120 Dec 10 '10 at 1:25
    
So glad you got it working. Sorry for the missing steps, I did quite some time ago and didn't remember the order in which I completed the steps. Good luck with your 600E, I've been using mine for 11 years. –  Weldon Brooks Dec 10 '10 at 4:02
    
Please note /usr/share/doc/alsa-utils/README.init.cs4236, which we've shipped since Jaunty. –  Daniel T Chen Dec 10 '10 at 5:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.