Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to boot Ubuntu from my USB, but my laptop stays stuck at the black "hp" screen. I've tried tapping F9 to get to my boot menu, and even f10 to enter BIOS....but nothing seems to work. What should I do?

My notebook is an HP G61-429WM. I purchased a new harddrive so there is no current OS.


Found an OS disc for Vista, going to try and install onto my notebook.

share|improve this question
Welcome Mari, Firstly have a look at this Q&A to identify you have prepared things correctly up to now.… – stephenmyall Jul 25 '12 at 14:48
Thank you for the link. I would also like to add more info. I had to purchase a new internal harddrive yesterday because my previous one was damaged. I downloaded Ubuntu through my desktop and used "Universal USB Installer " to copy onto my USB. I'm going to read over the link you provided. Thank you. – Mari Jul 25 '12 at 14:52
@Mari- set your BIOS setting to defaults and try again. – atenz Jul 25 '12 at 15:22
Still no luck. And installing Vista from the CD didn't work either. Is there probably something else wrong with my notebook? – Mari Jul 25 '12 at 15:38
according to… in addition to f10, you might want to try f2 or f6 – Scott Goodgame May 26 '13 at 3:06

Try to reset the BIOS by e.g. removing the CMOS battery and see if that works. It could also be defective RAM. I've had that if I had bad RAM the computer wouldn’t get past the BIOS loading screen.

share|improve this answer
There are also more ways to reset the BIOS. Most mainboard manufacturers implement a special reset key combination, for example to hold PAGE-UP while turning the power on. – Byte Commander Sep 30 '15 at 18:50
Huh, never knew that. Thanks for the info! – ACluelessProgramer Sep 30 '15 at 21:54

Welcome Mari, BIOS key is mostly one of F2 , F8, F9, F10, F12, or delete.

share|improve this answer
Yes, mine is F10 for BIOS. The issue is that, whenever I insert my USB into a port and turn on my laptop, it stays stuck on the "hp" screen and does not go anywhere regardless of what key I tap. Thank you for the welcome. – Mari Jul 25 '12 at 14:58
Let me guess PNY? – TheXed Oct 8 '13 at 16:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.