Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have multiple Ubuntu clients connecting trough vpnc to a Cisco ASA 5510. The VPN connection is configured trough network-manager-vpnc-gnome. All clients (separate user names and passwords, same group name and password) connect fine, get issued a 10.77.22.x IP and are able to access the web server on same network.

Now here comes the fun part. Although all clients can get web pages from said server, SOME of them can't post page updates (like, user fills out text boxes, clicks save/submit). Furthermore, if the web page with editable content is in the main browser window, it works on all clients. If the page is in a pop-up window, the page doesn't get posted.

Tried this with Chrome and Firefox, both latest versions. Tried it without any extensions enabled, incognito/private mode. All clients run Ubuntu 11.10, all up to date and all of them run the same Firefox, Chrome and vpnc versions.

I haven't got admin access to the Cisco box. The same two clients can't update pages regardless of their location (different routers, cable, adsl, etc.) while all others can regardless of location.

So, I realize there's no ready-made answer to this, I'd appreciate some pointers as to how to debug/monitor traffic on a "healthy" machine and then compare it to the "faulty" ones.

share|improve this question
add comment

1 Answer

Alright, hope someone finds this useful and doesn't have to spend hours trying to figure it out. The two clients in question were fixed after lowering their MTU to 1200 (1300 worked but had one hiccup while connecting from a coffee shop, so left it at 1200 for both). So all you have to do is include ifconfig tun0 mtu 1200 in your /etc/NetworkManager/dispatcher.d/vpn-up script.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.