Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok so I tried for the first time to use PGP keys for email encryption in Evolution. I followed some instructions online, created a key, but coz I encountered some problems I decided to delete the key and restart the proces. (This fact is probably irrelevant, because I got similar errors when doing it.)

Now I have no key and I go to Remote: Sync and publish keys. Firstly it says that there are 6 keys selected for synchronisation. Why? I do have some passwords saved in here, will it sync those too??

And last, when I click sync I first get two errors:

Couldn't retrieve keys from server:

Couldn't communicate with server '': Internal Server Error


Couldn't retrieve keys from server:

Couldn't communicate with server '': Internal Server Error

Than the progress stops and no progress is made, it just says:

Synchronising keys... Exporting data

Any help?

share|improve this question
Can you post the keyservers available in seahorse , through the same sync option menu. – atenz Jul 25 '12 at 14:58
hkp://, hkp:// and ldap:// these are the keyservers i have by default. – Janez Fouclait Jul 25 '12 at 15:33
They are right , have you tried revoking them. do you have any firewall like UFW installed and enabled. – atenz Jul 25 '12 at 15:53
Because I wanted to start over(and some error in evolution about public key), I deleted all keys in preferences. Regarding the firewall- I have a pretty much clean install and have not messed with firewall preferences, but I think it is on by default in ubuntu? – Janez Fouclait Jul 25 '12 at 16:05
Then not a firewall issue. have you integrated pgp to evolution mail. – atenz Jul 25 '12 at 16:36

I had the same problem. I fixed it by:

  1. Remove all existing keyservers from the Sync box (by default hkp://, hkp://, and ldap://
  2. Add them over again (keeping the same settings).
  3. Press Sync.

Don't know why this works, but it does.

share|improve this answer
Hey" I tried removing and adding back keyservers, but the problem still persists. – Janez Fouclait Aug 12 '12 at 11:27

Try this solution from ubuntuforums.

gpg --gen-key --enable-dsa2

Hope this helps!

share|improve this answer
How would this be helping the user? This isnt the user's issue, his issue is syncing the keys, not creating a key. – Thomas Ward Jul 25 '12 at 14:04
Agreed. I can create the key without a problem. – Janez Fouclait Jul 25 '12 at 15:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.