Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue with this application called "Sandboxgamemaker". First of all, it did not install properly as the Software Center was struck at "Applying Changes". When I opened the Update Manager in order to recover, it warned me to not to proceed without a 'partial update', which is of-course for the improperly installed Sandboxgamemaker app.

As I did, the Update Manager stopped responding and I thought of doing it manually. So I used the below command

sudo dpkg --configure -a

Both in the Update Manager and in the terminal, despite trying for all the given options of

replace PlatinumArtsSandbox2.6.1/bin/jpeg.dll? [y]es, [n]o, [A]ll, [N]one, [r]ename:

I'm struck here, as shown below

Processing triggers for python-central ... Setting up sandboxgamemaker (2.6.1+dfsg-7) ... Cleaned old data --2012-07-25 18:05:21-- http:// sandboxgamemaker. com/sandbox/PlatinumArtsSandbox2.6.1Multiplatform.zip Resolving sandboxgamemaker.com... 173.236.241.215 Connecting to sandboxgamemaker.com|173.236.241.215|:80... connected. HTTP request sent, awaiting response... 301 Moved Permanently Location: http:// www.sandboxgamemaker. com/sandbox/PlatinumArtsSandbox2.6.1Multiplatform.zip [following] --2012-07-25 18:05:23-- http:// www. sandboxgamemaker. com/ sandbox/PlatinumArtsSandbox2.6.1Multiplatform.zip Resolving www. sandboxgamemaker. com... 173.236.241.215 Reusing existing connection to sandboxgamemaker.com:80. HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

replace PlatinumArtsSandbox2.6.1/bin/jpeg.dll? [y]es, [n]o, [A]ll, [N]one, [r]ename:

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Well you could try sudo apt-get update --fix-missing and fix any missing dependencies on your computron. :) If that doesn't work, try removing it and reinstalling. See if you get the same issue.

share|improve this answer
    
Thank you very much @UrFriendlyVirus. I did the --fix-missing thing, it updated few things, but in the end all it showed me was > E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. –  Sunit Prasad Jul 27 '12 at 5:42
    
Glad to hear your problem is resolved @Sunit Prassad! –  themidnightowl Jul 27 '12 at 12:41
    
No no.. sadly, it didn't.. I tried your suggestion, after few steps of execution, it again asked me to run the "sudo dpkg --configure -a" and that is what is my problem as I mentioned!! please look at the screen shots from the below link... goo.gl/X1Mqk –  Sunit Prasad Jul 27 '12 at 15:41

Got the answer.

First I used this code

sudo apt-get update --fix-missing

when it completed its execution, I tried to force remove the faulty application by a simple

sudo dpkg -r –force-depends

and then finally

sudo dpkg --configure -a

and bingo problem solved!

Thank you very much @UrFriendlyVirus

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.