Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS k52f and the web cam is mounted upside down. So I have to do a workaround for the web cam to show a proper image.

But the problem is, this workaround only works with Skype 2.x versions. And Skype recently updated to 4.x versions. In the Ubuntu repositories i.e. the software center, they still have the 2.x version.

How do I get the .deb file from the software center so that I could save it and use it in case Ubuntu updates its repositories?

share|improve this question
    
Can you please specify which Skype version do you want? –  Mitch Jul 25 '12 at 9:30
    
When I open ubuntu software center, this is the version that I downloaded and used 2.2.0.35 –  Schweinsteiger Jul 25 '12 at 10:25
add comment

2 Answers

up vote 1 down vote accepted

If Skype 2 is what your after, then you can downloaded it Here. And it installs the same way as below. To download Skype 2.2.0.35 32bit or 64bit Click here.

To install Skype 4.x, download it Here. Choose 32bit or 64bit depending on your platform. One downloaded, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, navigate to the download folder, probably Downloads, and run the command below.

For 32bit

sudo dpkg -i skype-ubuntu_4.0.0.8-1_i386.deb

For 64bit

sudo dpkg -i skype-ubuntu_4.0.0.8-1_amd64.deb

Another way to install . GDebi. To install it press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below:

sudo apt-get install gdebi

Or click below

Once you have installed GDebi, use the File Browser to find the package you wish to install, and double click on it.

share|improve this answer
    
Why the down-vote? :) –  Mitch Jul 25 '12 at 9:09
    
thanks a lot for the link for the download, that version also works well with LD_PRELOAD, but do you have 2.2.0.35. That is the latest version that works with LD_PRELOAD. 4.x does not work with LD_PRELOAD. In the ubuntu repo, they have the 2.2.0.35. If there is anyway i could download that, it would be awesome. –  Schweinsteiger Jul 25 '12 at 10:28
    
@VarunSchweinsteigerVenkatesh I added the download link for 2.2.0.35 in my answer. See the second line of my answer. If you feel that this answers your question, you may mark this answer as accepted. –  Mitch Jul 25 '12 at 10:56
add comment

http://pkgs.org/download/skype

From there, you can download any version available until today. This site is confusing so, don't mess up.

Select your Linux distro / Skype version

Select 32bit or 64bit

Click "Select Mirror"

Then download Binary Package !

Skype may require, additional depency files, which you can download from http://pkgs.org

It's highly recommended to use the latest version

Good Luck!

share|improve this answer
    
Well,that is exactly what I was looking for. I know it is recommended to use the latest package,but skype 4.x doesnot support LD_PRELOAD which i require since, my webcam is mounted upside down. –  Schweinsteiger Jul 25 '12 at 10:34
    
.and,could you please explain what do you mean by Skype may require, additional depency files . –  Schweinsteiger Jul 25 '12 at 10:40
1  
Some programs are not stand alone .deb files. They need other *.deb files to be installed before installing the main program. They are called dependencies (like skype-bin I think ) without those deb files, the main program refuses to be installed. It doesn't matter if you have already installed Skype. There is a web cam virtualizer for Linux, which may help you to fix the issue with Skype 4. Visit : ws4gl.org –  Naveen Jul 25 '12 at 11:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.