Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to change the tcp timestamps in Ec2 instance (which is Ubuntu 12.04). I opened up the editor and changed the value 1 from 0. And when I tried to save the file I get this error:

/proc/sys/net/ipv4/tcp_timestamps" E667: Fsync failed

I'm very new to Ubuntu. Can anyone help me in this out?

share|improve this question
up vote 14 down vote accepted

Your editor is probably doing funny things to that file (files in /proc are not actual files, they're an interface to lower-levels of the operating system). While the change is probably working okay, the usual way of updating things in proc is directly with a shell command, like:

echo 1 | sudo dd of=/proc/sys/net/ipv4/tcp_timestamps

If you want this setting to be applied every time you boot, create a file called /etc/sysctl.d/tcp-timestamps.conf, containing the following:

net.ipv4.tcp_timestamps = 1
share|improve this answer
This pattern (echo VALUE | sudo dd of=/path/to/file) is very useful. Thank you very much! – Malcolm Sep 10 '13 at 0:23
Worked for me too for this and to set other kernel parameters. This helped for setting another kernel parameter called allow_tpm. echo 1 | sudo dd of=/sys/module/libata/parameters/allow_tpm – user349667 Nov 17 '14 at 22:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.