Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to change the tcp timestamps in Ec2 instance (which is Ubuntu 12.04). I opened up the editor and changed the value 1 from 0. And when I tried to save the file I get this error:

/proc/sys/net/ipv4/tcp_timestamps" E667: Fsync failed

I'm very new to Ubuntu. Can anyone help me in this out?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Your editor is probably doing funny things to that file (files in /proc are not actual files, they're an interface to lower-levels of the operating system). While the change is probably working okay, the usual way of updating things in proc is directly with a shell command, like:

echo 1 | sudo dd of=/proc/sys/net/ipv4/tcp_timestamps

If you want this setting to be applied every time you boot, create a file called /etc/sysctl.d/tcp-timestamps.conf, containing the following:

net.ipv4.tcp_timestamps = 1
share|improve this answer
    
Thanks... :) It worked for me.. –  batman Jul 25 '12 at 7:30
    
This pattern (echo VALUE | sudo dd of=/path/to/file) is very useful. Thank you very much! –  Malcolm Sep 10 '13 at 0:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.