Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I always had my Desktop folder empty, and so I deleted it. After restart, nautilus decided that it should use my home folder as a base, and now my desktop is cluttered with files from my home folder.

I tried recreating Desktop folder, nothing changed.

I tired setting apps/nautilus/preferences/desktop_is_home_dir key to true or false in gconf-editor, but nothing changed.

Also, I tried setting apps/nautilus/preferences/show_desktop key to false, it did hide all the icons, but also screws some visual effects.

Is there some way to convince nautilus back to using ~/Desktop folder as a base folder for desktop?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I do this to hide stuff on the Desktop in the Terminal type

cd ~/Desktop
ls > .hidden

then press

CTRL+R

to refresh the desktop and no files.

or the other option is to install

Install gnome-tweak-toolAdvanced Settings

enter image description here

Select Desktop from the sidebar

enter image description here

Turn OFF let file manager handle the desktop

share|improve this answer
    
I did that in my ~/, and it seems to work. And I even got to get rid of that Desktop folder! Thanks! –  Rogach Jul 25 '12 at 6:55
    
@Rogach OK you're welcome I expanded the answer with a nether option. –  zeitue Jul 25 '12 at 7:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.