Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use:

apt-get remove 

To remove some software, but it displays:

error:E: Internal Error, No file name for libssl1.0.0 .

I also try this to resolve the error:

sudo dpkg -i libssl1.0.0_1.0.0e-2ubuntu4.5_i386.deb

But it also gives an error :

 libssl1.0.0:i386 1.0.0e-2ubuntu4.5 cannot be configured because libssl1.0.0:amd64 is in a different version (1.0.1-4ubuntu5.3)

I want know the correct way to solve this problem.

share|improve this question

For me this works:

sudo dpkg --configure -a

Src: (E: dpkg was interrupted... run 'sudo dpkg --configure -a'...)

Reboot then,

apt-get update
apt-get upgrade

I hope it works for you too!

share|improve this answer
Worked for me. The installation of an update was interrupted by a full disk and after making room 'dpkg --configure -a' was enough to continue the installation. – Martijn Heemels Jun 10 '14 at 10:31

I also encountered this error on Ubuntu 12.04. I fixed it with the following commands:

sudo apt-get update
sudo apt-get clean
sudo apt-get install -fy
sudo dpkg -i /var/cache/apt/archives/*.deb
sudo dpkg --configure -a
sudo apt-get install -fy
sudo apt-get dist-upgrade
share|improve this answer
installing all packages in /var/cache/apt/archives is dangerous and unnecessary. – user72421 Jul 29 '12 at 20:27
might be dangerous but it worked like a charm. Thank you Eliah Kagan and user80001. I sure hope this dependancy hell with multiarch get's solved quickly. This is the second system that has been hosed by this problem and cost me several valueable hours to fix. – Kat Amsterdam Jul 31 '12 at 18:46
remember that with multi-arch all arches of the same package must be the same version. – user72421 Aug 2 '12 at 18:24
Worked for me too. And I don't think installing all packages from that directory is dangerous in this case. The apt-get clean takes care of that. – Pablo Oct 5 '12 at 10:57

use dpkg -i on both of these:
share|improve this answer

My problem stemmed from an unmet dependency for rhythmbox. Just the following 3 commands got rid of the dependency and error. These are from a previous posting.

error: E: Internal Error, No file name for libssl1.0.0

I just entered

sudo apt-get update
sudo apt-get clean
sudo apt-get install -fy
share|improve this answer

If the suggestion

sudo dpkg --configure -a

does not work for you, try to reinstall both packages libssl1.0.0:i386 and libssl1.0.0:amd64. You might have to force this because you temporarily break dependencies until these packages will have been reinstalled with the fourth of the followting command:

sudo dpkg --purge --force-depends libssl1.0.0:i386
sudo dpkg --purge --force-depends libssl1.0.0:amd64
sudo dpkg --configure -a
sudo apt-get -f install
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.