Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

LightDM is having major problems with the xserver and generic graphics driver on Ubuntu 12.04 LTS for me, and I really don't like the look and feel of GDM or LXDM, so I just want to disable the mouse on the LightDM login screen instead, to fix the jittery mouse problem and force guests to learn the arrow key method instead.

Is there a way I can do this?

share|improve this question
    
Do you mean the unity-greeter? lightdm is the backend service. You could try an alternative greeter like the gtk one. –  mfisch Jul 26 '12 at 2:23

1 Answer 1

First use the following command in terminal to find out your mouse id:

xinput list

Once you find it, run the following commands for editing lightdm.conf file with root privileges:

sudo -i
gedit /etc/lightdm/lightdm.conf

Add the following two lines at the end of lightdm.conf file:

greeter-setup-script=xinput --disable <mouse_id>
session-setup-script=xinput --enable <mouse_id>
#replace <mouse_id> with the id of the mouse that you found it with `xinput list` command

Save the file and close it and don't forget to close that root shell.

Now, reboot your system and use only the keyboard at the login screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.