Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my system is dual boot Win7 / 12.04

/etc/fstab looks oK

/boot on sda5
/     on sda6
/home on sda7

fdisk -l is fine shows 3 sep logical partitions

/dev/sda3                             Extended  ( group container for 5,6,7
/dev/sda5  nnnnn    nnnnn  500MG  83  Linux  <-- grub also here
/dev/sda6  nnnnn     nnnn  40 GB  83  Linux
/dev/sda7  nnnnn    nnnnn  60 GB  83  Linux

as listed above, before the attempted upgrade, / , /boot, /home were on 3 separate logical partitions and /etc/fstab looked OK.

what seems to have happened in the upgrade is that grub lost track of the 3 separate partitions and could not process a logon from a user whose /home directory was on another partition.

/var/logs/auth.log would show a failure for that user when i tried to logon after the upgrade...

lightdm: pam_succeed_if(lightdm:auth):requirement "user ingroup nopasswdlogin" not met by user "rob" 
[system] rejected send message, 2 matched rules; type='method_call', sender=':1.103' (uid=104 pid=nnnn comm='/usr/lib/indicator-datetime/indicator-datetime-ser') interface''org.freedesktop.dbus.properties' member='getall' error name='unset' .... 

I go to grub menu and go to 'recovery' for 3.2.0-27 then 'drop into root'...

if i look for /home there is NOTHING. if i look for /boot/grub , there is NOTHING

if i then go back to the sub-menu where i dropped into root , selecting 'grub updte bootloader' this time, i retreive the references to /home and to /boot/grub and everything looks consistent.

then , i try to reboot from the internal menu from recovery and it goes to the logon for my account , i give the passwd and it just dies with a back-lit screen.

So, im really stuck.. Unable to revert to 3.2.0-26 and unable to stitch together the grub components in order to go forward with 3.2.0-27.

i don't think anything is corrupted but grub seems to be confused and i do not know the sequence of commands to use to recovery to where i was on 3.2.0-26.

FOOTNOTE I wanted solution like 'aaa' says below where grub update would have been used to somehow restitch the elements of dual-boot back together. Matt scared me into a re-install from my USB stick which was vanilla amd64 ( dont think that it had the alternate solution ).

It looked like all the elements were there after using 3.2.0-26 recovery and grub recovery. It looked like grub was there - altho im not sure that it was back on /dev/sda5 where originally put it.

There seems to be something very brittle in the dual boot solution where Win7 is primary controller of MBR and MBR points to grub on /dev/sda5.

The funny thing is that after i reinstalled, i eventually got to 3.2.0-27 working on my laptop. I did this by doing apt-get update and then by responding to the shaking icon in Unity UI for updates. The big update included 3.2.0-27 update that had failed earlier . ONLY THIS TIME IT WORKED??

I can only say that the outcome of system software upgrades is suspect when you have the dual boot topology where orig Win7 MBR forwards to grub on the first of the logical sdaXX partitions created during an install where you choose to create your own partitions. I will be very wary of this situation when i decide whether to apply uprades when Unity prompts me.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I am currently dealing with the same exact issue. To fix it you are going to HAVE to reinstall Ubuntu. If you don't you will mess up the boot kernels on Windows 7 and Ubuntu and you will have to reinstall Windows 7 and Ubuntu from the ground up. Heed my warning when I tell you this. I followed instructions to fix this online and it ended up deleting all my previous kernels.

share|improve this answer
    
thanks .. MBR record is still ok. grub reference to Win7 option is still fine.. i can boot to Win7 fine. thx for advice .. will wait awhile to see if some grub expert bails me out.. then i will re-install from the orig USB stick. –  rowntreerob Jul 24 '12 at 21:41
    
its a new laptop.. i guess that ill just backup my work of 3 days from /home and then re-install. Thank u Matt –  rowntreerob Jul 24 '12 at 21:44
    
No problem if you run into anymore issues let me know. Don't forget to help with rep. –  Matthew Kaulfers Jul 24 '12 at 21:52

I ran into this same problem (Lubuntu 12.04 64-bit). During the upgrade process from 3.2.0.26 to 3.2.0.27, all files in /boot/grub seem to have been deleted so GRUB cannot start. I fixed GRUB by using the Lubuntu "AMD64 alternate install" disk and choosing "Rescue a broken system". After answering all the various setup questions, choose the root partition of the broken system for the root prompt from the list of partitions (eg /dev/sdb1). Then execute sudo grub-install /dev/sdb (assuming the previous MBR was on /dev/sdb) followed by sudo update-grub and reboot. This worked for me.

In your case, it looks like you need to choose a root prompt into /dev/sda6. The reason you don't see anything in /boot or /home is because the partitions /dev/sda5 and /dev/sda7 are not mounted. Because you have /boot on a separate partition you need to mount it. Assuming the file system is ext3, the command is:

sudo mount -t ext3 /dev/sda5 /boot

Then execute sudo grub-install /dev/sda followed by sudo update-grub and reboot. The update-grub command should find and list all the various operating systems on your partitions including Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.