Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Prior to the most recent update, I have been able to use LiveMocha with FlashPlayer. Now FlashPlayer is unrecognized by LiveMocha. I get the "Get Flash" message. How do I fix this?

share|improve this question
Could you please tell us what browser are you using (e.g. Firefox, Google Chrome or Chromium) and what version (usually in Help > About menu or chrome://chrome/ for Chrome)? Also, make sure you have either adobe-flashplugin, or flashplugin-installer package installed. – jnv Jul 24 '12 at 17:43
I would really, really love to be able to use LiveMocha with Firefox :( Nonetheless, the Chrome solution can save the day. – brandizzi Nov 7 '12 at 17:48

I did this steps and been able to use FlashPalayer in LiveMocha. This lines install the Google Chrome stable, that comes with FlashPlayer 11.4.

  1. Run wget -q -O - | sudo apt-key add -.

  2. gksu gedit /etc/apt/sources.list.d/google.list (opens a graphical text editor)

  3. Paste the text: deb stable main

  4. Run sudo apt-get update.

  5. Run sudo apt-get install google-chrome-stable.

share|improve this answer

I recently ran into this problem and none of the workarounds using chrome worked. The latest version of flash for ubuntu is simply too outdated. I ended up installing the windows version of firefox using Wine so that I could install the latest version of flash. That worked for me.

share|improve this answer

Unfortunately, Livemocha's website is basically hostile to Linux in general. If you try to login to Livemocha today (18 August 2013 - maybe they will fix it), using either Firefox or Google Chrome, their site will not let you login or create an account if you are using Linux.

I have to say that up to now I have never encountered a webpage (even on that is quite as hostile to Linux as this. I am a long-time Livemocha user, and even paid for an account there (which I now regret), but I think it's time to move to one of the alternative language-learning sites.

share|improve this answer

Hi I figured that livemocha requires flash version 11.3 or higher and somehow my firefox and chromium browser were showing 11.2 in . I reinstalled chrome browser and the site worked in chrome browser. I believe reinstalling of browser should solve the problem.

share|improve this answer

Just using the Google Chrome browser worked for me.

(note: this makes sense, since Chrome comes with its own version of flash built in)

share|improve this answer
google-chrome --user-agent="Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.17 Safari/537.36" 

Use that in terminal to bypass the linux hostility. However, if you have chromium and not chrome, you are on your own

share|improve this answer

I had the same problem, whenever I try to log in it shows me this error message:

Livemocha is not supported on Linux.

Visit us from your Mac or PC to access the full Livemocha experience. We can't wait to see you there!

Livemocha is not supported on Linux.

But, when I ran this command on the Terminal, it worked:

chromium-browser --user-agent="Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.17 Safari/537.36"

Here, it works.

enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.