Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I've a new Dell Inspiron special edition with Intel® Core™ i7-3612QM and Ati Radeon HD 7730M. I'm running Ubuntu 12.04 in dual boot with Windows 7.

Yesterday after a kernel upgrade from 3.2.0-26 to 3.2.0-27, Ubuntu doesn't boot anymore. I see the grub and when selecting "Ubuntu with Linux 3.2.0-27-generic", the system switched to a black screen with blinking cursor. No console enabled, at this time I can only shutdown the system with the power button.

If I select previous Linux version, Linux 3.2.0-26 starts without a problem.

I've open /boot/grub/grub.cfg and record of version 27 and 26 have same parameters.

Is it possible that the problem come from error in 3.2.0-27 kernel's file? How can I fix this issue? Is it possible to remove 3.2.0-27 kernel file and reinstall?

share|improve this question

marked as duplicate by Web-E, Jorge Castro, Mitch, jokerdino, fossfreedom Jul 26 '12 at 20:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
See this answer askubuntu.com/a/162078/35775. This is because of graphics driver. –  Web-E Jul 24 '12 at 14:47

2 Answers 2

Qualified success: I got my keyboard & mouse working via BIOS, then selected safe mode for 3.2.0-27-generic. Once in, a menu of options comes up, including an option to update grub. I did so, then selected the option for a normal boot (again, using 3.2.0-27-generic) and am currently running... apparently with no issues. I'm backing up b/f trying a reboot to see if the fix is permanent. Will report back if issue resolved.

share|improve this answer
    
Not sure if this resolved anyone else's issue, but it appears mine is fixed. After update noted above, system rebooted without a hiccup running 3.2.0-27-generic. Hope someone finds this helpful. –  Matt 6-27 Jul 24 '12 at 18:18

Warning: This method runs the risk of purging all installed kernels and leaving the system unbootable.

I've experienced a similar problem after upgrading to 3.2.0-27 kernel. I could select which kernel to boot from in grub but can only boot completely via recovery.

What I did was boot up into 3.2.0-26 recovery, removed 3.2.0-27 as well as the graphics driver. After rebooting, I picked 3.2.0-26 generic and was able to boot up to it. Reinstalled the graphics driver and now everything seems to be working fine.

I ran this command in terminal to remove the new kernel:

sudo apt-get remove --purge 3.2.0-27-*

Then reinstalled the graphics driver via System Settings > Additional Drivers which installed the latest Catalyst 12.6 on my system.

As is usually the case with software, your mileage may vary.

share|improve this answer
    
I've tried to run boot repair from live usb but nothing change.. Fortunately i can boot in 3.2.0-26 version.. I will continue to use that version.. –  IncioDev Jul 24 '12 at 16:36
    
Purging Kernels is quite dangerous, can you list a way that changes the default kernel in grub instead of removing the kernel, as this could leave some systems unusable. –  Mateo_ Jul 24 '12 at 19:06

protected by Community Jul 24 '12 at 20:29

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.