Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug my 3G USB Viettel modem to my case, it is not working. I have tried to access the network icon in the top panel, then I set up the connection, removed it and plugged it in again, but still it is not working.

My 3G USB is from Huawei. Please help me.

share|improve this question
    
The answer below is likely the correct workaround, but to make sure. Could you type this commnd in terminal 15 seconds after you plug in your usb modem: lsusb and give us the output. –  Hanynowsky Oct 28 '12 at 13:59
add comment

1 Answer

Step by Step guide to use Huawei E1550 USB stick on Ubuntu: 1. Plug in Huawei E1550 USB modem to USB port. You can notice its icon is loaded on Desktop.

  1. Type following command at command prompt: gksu gedit /etc/udev/rules.d/15-huawei-e1550.rules

  2. It will open gedit. Type following lines in it and then save it and close the file:

    • SUBSYSTEM=="usb"
    • SYSFS{idProduct}=="1446"
    • SYSFS{idVendor}=="12d1"
    • RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"
  3. Restart the computer. After restart click on "Network connection" icon in the top panel. You will see new menu item under "Mobile Broadband" category.

  4. Click on that new entry. It will open a New Mobile Broadband Connections dialog. Click Forward to continue.
  5. Select you country (Singapore in my case) and click Forward. Then select service provider from the list and click forward. Then choose your Billing plan and click Forward. Then finally Click on Apply to save setting.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.