Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently using Evolution for my mail client on 12.04 (and no, I don't want to use Thunderbird), but the version available in the repos (3.2) has a couple of bugs (more precisely, its version of EWS has the bugs) that are fixed in later versions.

Is there a PPA available for at least 3.3? While I have no issue compiling from source, I'd rather use a PPA if it's available, but unfortunately, my own searching didn't turn up anything.

Edit Thanks to JXPheonix for finding a PPA. I added it and found that apt-get upgrade didn't want to just update Evolution and had several of the Gnome 3.4 packages held back. Installing Evolution specifically with apt-get install evolution worked great, though.

(Since Ubuntu was pretty adamant about not updating Evolution, I decided to see what I could find as to why, beyond the generic "stability reasons" that was given for everything they held back. According to this article, it seems it's just because 3.4 wasn't as well-tested as 3.2 as of Precise's release.)

For those using EWS, you will need to update evolution-ews, of course. I found this script useful for building and installing EWS. It's originally written for 3.2, but a simple change to the script to point to the correct download location (simply change the "3-2" in the Git repo clone call to "3-4") allows it to install with no problems. After updating EWS, my Exchange account is back up, complete with the global address book and Exchange calendar!

share|improve this question
    
I've tried the stracciatella PPA. That would bring too much new gnome stuff. I'll wait the few days for 12.10, let's see what that brings. –  Ondra Žižka Oct 18 '12 at 2:04
    
BTW, Evolution 3.2 is buggy as hell. It deleted 2 IMAP folders from the server when moving them failed! –  Ondra Žižka Oct 18 '12 at 2:06
    
@OndraŽižka - You don't need to add all the other Gnome stuff. In fact, Ubuntu fights you if you try to just do an update. Hence the first paragraph after Edit. –  Shauna Oct 19 '12 at 2:11
    
Doesn't then Ubuntu update the other gnome stuff on periodical update check? –  Ondra Žižka Oct 22 '12 at 5:39
    
@OndraŽižka - Ubuntu will not upgrade the Gnome items from the PPA. That is why you have to explicitly tell it to install Evolution. –  Shauna Oct 22 '12 at 21:08

2 Answers 2

up vote 4 down vote accepted

Use this code to add the repo:

sudo apt-add-repository ppa:gnome3-team/gnome3

Evolution is by the same people as gnome3, so this should contain evolution 3.4.3 (unless my information is outdated.

EDIT: OK, I found a PPA with evolution 3.4.2. However, it is unofficial, so use at your own risk.

sudo apt-add-repository ppa:janvitus/gnomestracciatella

I can't find any with 3.4.3, but this one will probably be updated at some point in the near future.

share|improve this answer
    
3.2.3 is still the latest available in the repo. :( –  Shauna Jul 24 '12 at 14:33
    
Awesome, it works like a dream! –  Shauna Jul 24 '12 at 15:33
    
Just to get this clear: adding the second (gnomestracciatella) repo, doing an apt-get update && apt-get install evolution worked without problems and side-effects? As I also have several problems with Evolution (see 12.04 - Evolution in Precise laggy for example), this update might offer some solution to me as well. As I have no need for MS Exchange support, I probably could skip the EWS part? –  Izzy Sep 1 '12 at 16:59
    
@Izzy - I've been using it with this setup for a couple of months now and have found no major side effects. The worst issue I've come across is that it sometimes will close the expanded attachments section on a received email while in the split view (the behavior is easily corrected by clicking a different email, then going back to the one with attachments). –  Shauna Oct 9 '12 at 13:49
    
@Shauna Thanks a lot! So I will give this a try when I return from my vacation. With some luck, it solves the laggyness here (which I attribute mainly to the switching away from Bonobo, so I'm confident a newer version will improve this). Feel free to recommend this on the linked question and grab the bounty for it before it expires. Would be a shame, as my question there has no answer yet... –  Izzy Oct 9 '12 at 14:05

You can download the source code from the internet and then compile and run it.

http://projects.gnome.org/evolution/download.shtml

share|improve this answer
    
As I said in my question, I would prefer to use a PPA if available. I am already aware that the source code is available. –  Shauna Jul 24 '12 at 13:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.