Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem with dependencies in the qt4 library, and I'm not able to install anything via the apt-get command.

apt-get update gives me a normal output.

apt-get clean and apt-get autoclean do the same.

apt-get-install -f gives the following output:

dpkg: errore nell'elaborare libqt4-xmlpatterns:i386 (--configure):
 libqt4-xmlpatterns:i386 4:4.8.1-0ubuntu4.1 cannot be configured because libqt4-xmlpatterns:amd64 is in a different version (4:4.8.1-0ubuntu4.2)

dpkg: errore nell'elaborare libqt4-xmlpatterns (--configure):
 libqt4-xmlpatterns:amd64 4:4.8.1-0ubuntu4.2 cannot be configured because libqt4-xmlpatterns:i386 is in a different version (4:4.8.1-0ubuntu4.1)

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-declarative:i386:
 libqt4-declarative:i386 dipende da libqt4-xmlpatterns (= 4:4.8.1-0ubuntu4.2), ma:
  La versione di libqt4-xmlpatterns:i386 nel sistema è 4:4.8.1-0ubuntu4.1.

dpkg: errore nell'elaborare libqt4-declarative:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-declarative:
 libqt4-declarative dipende da libqt4-xmlpatterns (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqt4-xmlpatterns non è ancora configurato.

dpkg: errore nell'elaborare libqt4-declarative (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqtgui4:i386:
 libqtgui4:i386 dipende da libqt4-declarative (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqt4-declarative:i386 non è ancora configurato.

dpkg: errore nell'elaborare libqtgui4:i386 (--configure):

problemi con leSegnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
              Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
            Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                                                                                    Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                                                             Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                                      Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqtgui4:
 libqtgui4 dipende da libqt4-declarative (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqt4-declarative non è ancora configurato.

dpkg: errore nell'elaborare libqtgui4 (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-designer:
 libqt4-designer dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-designer (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-designer:i386:
 libqt4-designer:i386 dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4:i386 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-designer:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-help:
 libqt4-help dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-help (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-opengl:
 libqt4-opengl dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-opengl (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-opengl:i386:
 libqt4-opengl:i386 dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4:i386 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-opengl:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-qt3support:i386:
 libqt4-qt3support:i386 dipende da libqt4-designer (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqt4-designer:i386 non è ancora configurato.
 libqt4-qt3support:i386 dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4:i386 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-qt3support:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-scripttools:
 libqt4-scripttools dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-scripttools (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-scripttools:i386:
 libqt4-scripttools:i386 dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4:i386 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-scripttools:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-svg:
 libqt4-svg dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-svg (--configure):
 problemi con le dipendenze - lasciato non configurato

dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-svg:i386:
 libqt4-svg:i386 dipende da libqtgui4 (= 4:4.8.1-0ubuntu4.2), ma:
  Il pacchetto libqtgui4:i386 non è ancora configurato.

dpkg: errore nell'elaborare libqt4-svg:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato

Si sono verificati degli errori nell'elaborazione:

libqt4-xmlpatterns:i386

libqt4-xmlpatterns

libqt4-declarative:i386

libqt4-declarative

libqtgui4:i386

libqtgui4

libqt4-designer

libqt4-designer:i386

libqt4-help

libqt4-opengl

libqt4-opengl:i386

libqt4-qt3support:i386

libqt4-scripttools

libqt4-scripttools:i386

libqt4-svg

libqt4-svg:i386

I've found this thread: Canot resolve package dependencies

but I wasn't able to remove and reinstall all the packages with dpkg -r, because I kept getting problems with dependencies while removing. It seems to me that I have problems with the different versions for different architectures in libqt4-xmlpatterns:

errore nell'elaborare libqt4-xmlpatterns:i386 (--configure):
 libqt4-xmlpatterns:i386 4:4.8.1-0ubuntu4.1 cannot be configured because libqt4-xmlpatterns:amd64 is in a different version (4:4.8.1-0ubuntu4.2)
dpkg: errore nell'elaborare libqt4-xmlpatterns (--configure):
 libqt4-xmlpatterns:amd64 4:4.8.1-0ubuntu4.2 cannot be configured because libqt4-xmlpatterns:i386 is in a different version (4:4.8.1-0ubuntu4.1)

In var/lib/dpkg/status I have the following about this package:

Package: libqt4-xmlpatterns
Status: deinstall ok unpacked
Multi-Arch: same
Priority: optional
Section: libs
Installed-Size: 4543
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Architecture: amd64
Source: qt4-x11
Version: 4:4.8.1-0ubuntu4.2
Config-Version: 4:4.8.1-0ubuntu4.1
Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libqt4-network (= 4:4.8.1-0ubuntu4.2), libqtcore4 (= 4:4.8.1-0ubuntu4.2), libstdc++6 (>= 4.1.1)
Pre-Depends: multiarch-support
Description: Qt 4 XML patterns module
 Qt is a cross-platform C++ application framework. Qt's primary feature
 is its rich set of widgets that provide standard GUI functionality.
 .
 QtXmlPatterns is a XQuery and XPath engine for XML and custom data models.
Homepage: http://qt.nokia.com/
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>

Package: libqt4-xmlpatterns
Status: deinstall ok half-configured
Multi-Arch: same
Priority: optional
Section: libs
Installed-Size: 4257
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Architecture: i386
Source: qt4-x11
Version: 4:4.8.1-0ubuntu4.1
Config-Version: 4:4.8.1-0ubuntu4.1
Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libqt4-network (= 4:4.8.1-0ubuntu4.1), libqtcore4 (= 4:4.8.1-0ubuntu4.1), libstdc++6 (>= 4.1.1)
Pre-Depends: multiarch-support
Description: Qt 4 XML patterns module
 Qt is a cross-platform C++ application framework. Qt's primary feature
 is its rich set of widgets that provide standard GUI functionality.
 .
 QtXmlPatterns is a XQuery and XPath engine for XML and custom data models.
Homepage: http://qt.nokia.com/
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>

I have tried dpkg --configure with no results.

share|improve this question
    
try this combo sudo apt-get update --fix-missing && sudo apt-get -t stable -f install && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y –  user827992 Jul 24 '12 at 13:51
    
also have a look at askubuntu.com/a/96137/72589 –  user827992 Jul 24 '12 at 14:01

1 Answer 1

I managed to fix the problem. I downloaded the latest versions of libqt4-xmlpatterns:i386 and libqt4-xmlpatterns:amd64 (from precise-updates), and installed them using dpkg -i. Then I ran dpkg --configure -a to configure all remaining packages. After that apt-get gave no problems. Thank you very much for the answers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.