Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I experienced the following problem when trying to change brightness either through the system settings of the shell, or by using fn + f2 fn+f3 combinations. The brightness bar appears in the top left corner of the screen and the whole system becomes non-responsive. Trying to change the brightness with xrandr works without problems, though. The laptop uses an Nvidia optimus card. The problem appears both with the nvidia-current driver installed and without it.

Is there any way to disable what causes this failure?


Thank you for your help it almost works now. I can reduce the brightness with the buttons and through the shell, though I can't increase it back. In this path /sys/class/backlight i have two similar directories. One called Samsung and one called intel_backlight. If I try to modify the values in the Samsung I cannot get more than 3 out of 8. However if I modify the intel_backlight I can increase back to max.

share|improve this question

1 Answer 1

To get working brightness key. try following

execute sudo gedit /etc/default/grub

Change this line

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

to something like below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Execute sudo update-grub and reboot . See if brightness keys are working.

It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.


This is for setting brightness manually after doing the above steps.

Try following for paths shown by ls /sys/class/backlight/*/brightness and replace accordingly.

example paths will be like

/sys/class/backlight/acpi_video0/brightness
  1. For the above path Get the maximum brightness:

cat /sys/class/backlight/acpi_video0/max_brightness

Try a lower value to set the brightness, say output is 16 so I will try with half of it

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0

Also don't install nvidia-drivers in an optimus enabled laptop, you need bumblebee. See discussion over here How well do laptops with Nvidia Optimus work?

Please let us know the results.

share|improve this answer
1  
I had this problem on my samsung QX411 (nvidia optimus) after a recent update. Changing the brightness caused flickering and non-responsiveness (if I dropped to console, logging in caused a repetition of ^@ symbols). Putting in the acpi_backlight=vendor line into my grub worked, but now you can't get full brightness unless you plug the laptop in. Tried the manual setting from CLI, and still doesn't work (it reports max_brightness is 3!) –  Ian B. Jul 31 '12 at 0:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.