Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Plowshare knowing that it can download rapidshare files from terminal, but if there are any parentheses () or brackets [] in the link then it can't download the link.

Can this problem be solved by any means? I mean by editing the configuration file or something?

share|improve this question
just show the link? I am not quite sure what you mean, you mean like ? – Dr_Bunsen Jul 24 '12 at 8:29
you got the newest? – Dr_Bunsen Jul 24 '12 at 8:34
@Dr_Bunsen how would updating plowshare would solve is problem? I looked into the change log but I can't find anything related to the problem. – LiveWireBT Jul 24 '12 at 11:35
@LiveWireBT dno, I googled the problem, and some guy suggested updating, and his thingy worked. you tried escaping the characters? would be weird if it didnt do it for itself, but if it doesnt, it should help, O seeing the ansers, thats already suggested. – Dr_Bunsen Jul 24 '12 at 18:56

This is because parentheses are a significant character to the shell, and this is a CLI utility.

Either enclose your link in single quotes (which prevents special characters being interpreted) or precede any special characters with a backslash (the "escape" character).


plowshare 'my(link)'

plowshare my\(link\)

share|improve this answer

Such characters are supposed to be encoded for usage in URLs (known as percent-encoding or URL encoding). Browsers like Firefox show the URL in human readable form in the address bar, though when you copy it to the clipboard it is still encoded. There must be something wrong with either where you are getting the links from or plowshare needs a feature to convert and process those links correctly, like similar applications have.

In case of wget proper usage would look like this:


However putting link in single or double qoutes work, as well as escaping the characters in question with \:

wget ''

The latter one is the most time-consuming solution, as you have to know which characters to escape and it gets very messy pretty fast.

Of course I was searching for the mesh network routing protocol.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.