Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to check out the source code of opencog(cogbuntu) using bazaar using the commands they had mentioned in their wiki.

This is the code entered in the terminal

bzr branch -r40 lp:cogbuntu cogbuntu-11.10

This is the error I got

ERROR: Connection error: while sending CONNECT xmlrpc.launchpad.net:443: [Errno 113] No route to host

Can anyone explain how to make this thing work?

share|improve this question

2 Answers 2

Do you perhaps have a HTTP proxy? echo $http_proxy should tell you.

You may want to try:

 bzr branch -r40 https://bazaar.launchpad.net/+branch/cogbuntu cogbuntu-11.10

which will avoid the XMLRPC step.

share|improve this answer
    
I check the HTTP proxy, there was one. I remove the proxy using following command export http_proxy="" I get the same error even after doing this: bzr branch -r40 bazaar.launchpad.net/+branch/cogbuntu cogbuntu-11.10 When I try to branch using the above Bazaar command I get the following error: ERROR: Connection error: curl connection error (couldn't connect to host) on bazaar.launchpad.net/%2Bbranch/cogbuntu/.bzr/smart –  user1259621 Jul 25 '12 at 11:22
    
Does this error has something to do with curl download manager. I've tried it after doing both uninstalling & re-installing curl. But I get the same error How do I work this thing around? –  user1259621 Jul 25 '12 at 11:25

I had a very similar problem until recently.

First of all, if you are behind a proxy, you need to set https_proxy, NOT "http_proxy", because Launchpad uses https. If you have curl or wget, you can confirm your proxy setting is working by running something like this:

curl https://code.launchpad.net/

Secondly, there has been a long-standing bug about ssl certificates, which would prevent you from checking out projects through a proxy, even if correctly configured. This has been fixed in version 2.5.1. If you have an earlier version, even 2.5, you have to upgrade to 2.5.1 (the current stable).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.