Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when I tried opening google-chrome in Ubuntu 12.04 LTS, I received the following error:

[1976:2032:299999600:ERROR:shared_memory_posix.cc(171)] Creating shared memory in        /dev/shm/.com.google.Chrome.0ApmLo failed: No such file or directory
   [1976:2032:299999742:ERROR:shared_memory_posix.cc(174)] Unable to access(W_OK|X_OK) /dev/shm: No such file or directory
   [1976:2032:299999773:FATAL:shared_memory_posix.cc(176)] This is frequently caused by       incorrect permissions on /dev/shm.  Try 'sudo chmod 1777 /dev/shm' to fix.

However, when I tried

sudo chmod 1777 /dev/shm

, I discovered that /dev/shm did not in fact exist. I don't know what happened, and how to fix this?

share|improve this question
add comment

1 Answer

Since 11.10 Ubuntu migrated to /run/shm instead /dev/shm, see here.
To solve the problem, you can do a softlink like this:

sudo ln -s /run/shm /dev/shm
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.