Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm installing Ubuntu server 12.04 on Dell laptop and I frequently get an message as below:

3256.362200] sd 5:0:0:0: [sdb] Asking for cache data failed
[3256.362200] sd 5:0:0:0: [sdb] Assuming drive cache : write through

What does this message means and how can it be removed?

share|improve this question
2  
Harddrives have 2-64MB cache memory. USB-Sticks/flashcards do not. USB-Sticks/flascards are seen as SCSI drives. So someone made a mistake with the debug level of the driver for flashcards. @EliahKagan –  Rinzwind Aug 22 '12 at 7:53
    
@Rinzwind You may want to post this (perhaps expanded, perhaps not) as an answer, since it really does answer the OP's question. The other answers are just about the bug (and so are probably off-topic). Your comment, which explains what the message means, is spot-on. –  Eliah Kagan Aug 22 '12 at 7:54
1  
I'd say that the part where "how can it be removed" would be the most sought-after piece of information, and should definetaly be part of the answer? At least, is was the thing I was looking for: first find out what it is, so I can stop the messages. –  Nanne Nov 11 '12 at 14:45
add comment

7 Answers

What do the Asking for cache data failed and Assuming Drive Cache: write-through messages mean?

  • Hard disks have a small amount of RAM cache to speed up write operations. The system can write a chunk of data to the disk cache without actually waiting for it to be written to the disk. This is sometimes called "write-back" mode.

    • If there is no cache on the disk, data is directly written to it in "write-through" mode.
  • The Asking for cache data failed warning usually occurs with devices such as USB flash drives, USB card readers, etc. which present themselves as SCSI devices to the system (sdX), but have no cache.

    • The system asks the device: "Do you have a cache?" and gets no response. So it assumes there is no cache and puts it in "write-through" mode.
share|improve this answer
add comment

This is a reported bug and you need to go here to find it.

share|improve this answer
1  
Guess the resolution could be done with this command? sudo sh -c 'echo "options ums_realtek ss_en=0" > /etc/modprobe.d/ums-realtek.conf' –  Balder Jul 28 '13 at 2:25
add comment

Bug Circumvention

The bug seems to be related to the flash card readers many computers have. If you have such a reader and aren't using it you may be able to use the circumvention contributed by Neal McBurnett here, from the bug report Matthew Kaulfers kindly included in his answer.

sudo rmmod ums_realtek

This circumvention works for my laptop.

share|improve this answer
add comment

This was also asked and answered in an earlier Ask Ubuntu question in May: Errors in dmesg - Test WP failed, assume Write Enabled

If initially unloading the driver and then reloading it each time you require the reader is not a suitable solution, I would suggest to specify the ss_en=0 option to the driver as I originally did in this answer.

To summarise that answer:

  • either load the module manually after it has been rmmod with: sudo modprobe ums_realtek ss_en=0
  • or specify it in /etc/modules with ums_realtek ss_en=0 to make this change permanent.
share|improve this answer
add comment

I have the same problem in 13.10 Saucy Salamander. However, the above answers did not help me. I did the following:

sudo rmmod ums_realtek
sudo sh -c 'echo "options ums_realtek ss_en=0" > /etc/modprobe.d/ums-realtek.conf'
sudo modprobe ums_realtek

What this does, is remove the module, update the module load parameters. Then loads the ums_realtek module again.

No reboot required.

share|improve this answer
add comment

Tip

In 13.10 Saucy Salamander, this message keeps repeating. You can't get a prompt. If this on a laptop, and you have a spare memory card. Stick it in, and the message goes away until you can apply the proper fix. Yes, this is mentioned in another post. But it could save readers here a little time.

share|improve this answer
add comment

I didn't have SD card still was showing the error. What I did to resolve the issue is to pull out power and battery from my laptop and waited for a minute before plugging the power in and starting again. It worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.