Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a new user of Ubuntu and only recently have had problems with booting. It either fails to recognize my monitor or sends me directly to a grub screen rather than booting completely. This is my grub file:

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX="reboot=efi"
GRUB_GFXMODE=1920x1200x60

I'm curious about the reboot=efi. In my research, I've seen that they are not included in other codes. Could this be a problem?

share|improve this question
    
Please indicate your Boot-Info URL. This will help us understand your problem. –  LovinBuntu Jul 29 '12 at 0:04
    
paste.ubuntu.com/1118652 –  kara Jul 30 '12 at 1:52
add comment

1 Answer 1

I believe that "reboot=efi" is for when something fails. As for your grub menu if you change that line where it says

GRUB_TIMEOUT=10 

to

GRUB_TIMEOUT=0

You won't get a grub menu anymore. As for your resolution issues I am very good at dealing with and would love to assist with that also if you need.

Very Respectfully,

Matthew Kaulfers

share|improve this answer
    
thanks for the tip--I'll try it. As for resolution, I have a View Sonic VP2330wb. It is an older monitor, but I have a brand new dvi cable I'm using. Since this problem has started, once I get Ubuntu loaded, the resolution is really bad, and when I go to display settings, it says I have a laptop screen (I'm not using multiple monitors) and won't let me use a resolution higher than 1024x768. I would appreciate any help. –  kara Jul 26 '12 at 2:37
1  
Setting GRUB_TIMEOUT=0 is not recommended as you would be (nearly) blocked in case of problem with a kernel update. Better leave 1 or 2 seconds. –  LovinBuntu Jul 29 '12 at 0:03
    
Okay, that is good to go--just fixed that. –  kara Jul 30 '12 at 1:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.