Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I upgraded to Ubuntu 10.4 (Maverick), the upgrade process got stuck on the post-installation of the CUPS package. I had to kill processes and run several forced updates before I could finally get regular updated. Ever since I can't print - The printed file gets messed up and crashes the printer. I also can't re-install CUPS, as each time the installation hangs and I have to kill it before it completes.

I tried to find a workaround for this problem, but in vain. Does anyone know how to bypass this? Or at least why can the post-installation hang, and how to re-install a problematic package?

Some system specs and other hints: Dell D630 laptop running Ubuntu 10.4, Gnome desktop, standard LAN network, printing to an LPD server. Everything worked fine on 9.10. Also, the printed files themselves are not corrupted. The problem does not seem to be Evince-specific, but common to all printouts.

share|improve this question
    
Try to reinstall and check /var/log/messages, there might be some errors related to the install hang. –  João Pinto Dec 9 '10 at 9:55

2 Answers 2

I had a problem like this with a headless box that had once been a print server and only listened for TCP (vice Unix socket) connections.

The 10.10 init script for CUPS waits for the Unix socket to appear, and if your cups.conf doesn't specify one, you get the kind of hangs that you are describing.

Verify that cups.conf has a line like

Listen /var/run/cups/cups.sock

because /etc/init/cups.conf contains the (dumb IMHO) line:

# wait until daemon is ready
     while [ ! -e /var/run/cups/cups.sock ]; do sleep
 0.5; done
share|improve this answer
    
after adding the line "Listen /var/run/cups/cups.sock" to the file /etc/init/cups.conf ,and running dpkg --configure -a , cups configured nicely and installed. I am now able to print from my android tablet through a chroot of debian testing... thank you so much spennig. i also had to make the folder /etc/init and also create the file cups.conf but still worked. –  Joshua Robison Apr 16 '12 at 11:03

The post-install script is /var/lib/dpkg/info/cups.postinst. If you know a little bit about shell programming you can try to find the problem.

The hard way to bypass it is to add

exit 0

as the second line, but most likely this will not fix your printing system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.