Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I cannot find it in the keyboard settings at all. In previous versions there was a tick box saying something along the lines of "use meta key instead of alt to drag windows?"

So how can I prevent alt trying to do this? :)

share|improve this question
What's meta key? –  Joshua Siret Jul 23 '12 at 19:35
usually replaced it with the super key (the windows button) –  Harvey Newell Jul 23 '12 at 20:21
please re add the 12.04 tag as this was possible in standard ubuntu settings until this release –  Harvey Newell Jul 24 '12 at 18:53
Possible duplicated –  Braiam Feb 23 '14 at 19:04

3 Answers 3

up vote 1 down vote accepted

Here's the way to do it without messing with the keyboard layout.
Note: You must know that this is a compiz feature, I recommend you not to change the keyboard layout settings.

  1. Make sure you have gconf-editor. Also known as Configuration Editor. You can install it from the Software Center.
  2. Run it and browse to /apps/compiz-1/plugins/move/screen0/options/.
  3. Simply change initiate_button from <Alt>Button1 to <Super>Button1.
  4. And you're done.


NB: Maybe if you want the easier way to do it, mess with CCSM (compizconfig-settings-manager).

share|improve this answer
thank you SO SO SO much. this has been causing haywire with some special apps i use. true life saver –  Harvey Newell Jul 24 '12 at 18:47

Xubuntu 15.04

You simply set the "Key used to grab and move windows" under the Accessibility tab of the Window Manager Tweaks program found in the Whisker Menu.

You can even set it to None. But since Super on it's own doesn't open any dashy menus in XFCE I'm pretty comfortable using Super as the key used to grab and move windows.

Ubuntu 13.10

  1. Open a terminal (Ctrl+Alt+T) and type sudo apt-get install dconf-editor. Enter your password when prompted and after the installation is finished type dconf-editor to open the Configuration Editor.
  2. Now either hit Ctrl+F and use the hereby summoned field to search for mouse-button-modifier or navigate to org.gnome.desktop.wm.preferences and find the same.
  3. Change it's value from <Alt> to something else (<Super> will probably work best) and enjoy your improved workflow!

NB: Leaving the field empty will get you stuck in drag-mode, unable to click the "Set to Default" button. You can bring the focus to this button by pressing Tab until a fine orange rim shows up around it. Then press Space and repeat step 3.

share|improve this answer

Search keyboard layout, it's a tab in keyboard settings too. Press options and check out the screenshot, hope that helps.

enter image description here

share|improve this answer
did not help, i wanted to preserve all other uses of the alt key, sorry. –  Harvey Newell Jul 24 '12 at 18:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.