Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use awesomewm and I have installed gnome-do. When I start it, I see this:

[SystemService] Could not initialize dbus: Unable to open the session message bus.
(Do:3128): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
(Do:3128): libdo-WARNING **: Binding '<Super>space' failed!

It is clear, it cannot map space combination, because awesomewm uses this one. However, I can see gnome-do in my processes. How I can summon it? Some people tell me that I should see the gnome-do welcome window, but I don't.

I tried what is written in this post (http://askubuntu.com/questions/157195/force-rewrite-of-gnome-do-summon-binding-on-login-because-keeps-being-set-to-dis). But it does not work, because every time I restart gnome-do, my binding written by hands disappears.

share|improve this question

2 Answers 2

Running gnome-do again from the run dialog (if it is already running) will summon it. At that point you will be able to change the keyboard combination in preferences > keyboard.

share|improve this answer
    
I wrote in my post that I don't see the gnome-do window, when I start it. –  user14416 Jul 24 '12 at 18:07

I found a solution:

dbus-launch gnome-do

However, I don't know why I need to start gnome-do like this. Others start it normally. If you have a solution how to configure dbus to avoid dbus-launch, please, live a comment.

share|improve this answer
    
I recommend asking a separate question about this new, more specific problem. –  Eliah Kagan Jul 24 '12 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.