Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I retrieve movies and audio files from my Canon PowerShot S5 IS camera?

Shotwell only sees the pictures. Mounting the camera via "Places > Canon Digital Camera" and then clicking twice on the resulting desktop icon yields this error:

could not display "gphoto2://[usb:001,002]/"

There is nothing in /media.

gphoto2 error message

update: output of sudo fdisk -l

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3ee33ee2

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2364        2612     1999872   82  Linux swap / Solaris
/dev/sda2   *           1        2364    18979840   83  Linux
/dev/sda3            2613        4864    18089159+   f  W95 Ext'd (LBA)
/dev/sda5            2613        4864    18089158+   b  W95 FAT32

Partition table entries are not in disk order

Solution: install gphotofs, then Nautilus shows camera contents similar to a standard usb storage device (though note that gphotofs does not yet support adding to or deleting contents).

share|improve this question
How do you connect your camera?Through USB cable? – karthick87 Dec 9 '10 at 6:09
yes, through usb. – matt wilkie Dec 9 '10 at 6:26
Post the output of sudo fdisk -l with your your usb device(that is your camera) plugged in. – karthick87 Dec 9 '10 at 7:05
@karthick, added. – matt wilkie Dec 10 '10 at 22:35
up vote 3 down vote accepted

As a workaround you could try accessing the files via the command line. In this question,
gphotofs was suggested for mounting the camera.

share|improve this answer
gphotofs solved it, but not in the manner indicated! After installing gphotofs selecting the camera from the Places menu opens a Nautilus window showing the contents of the camera as standard usb storage device. – matt wilkie Dec 10 '10 at 22:51

Shotwell 0.8 will support video, including importing them off cameras:

We're considering adding audio support in a future release:

share|improve this answer

Well, i installed gphotofs but the camera does not appear under places.

The "sudo fdisk -l" shows only the disk drive, although lsusb certainly shows the camera.

And gphoto used to work in 9.10---although on a different computer: i'm using a new computer and 10.10 is the first OS to be on it.

I wouldn't mind using shotwell, but it does not import movies---fspot is very good about vacuuming all the data off the camera, whether it understands what it means or not.

So: although i can continue to us fspot on my 9.10 machine, i would prefer to be able to fully utilize 10.10.

Thanks in advance for any clues.

Well, in fact, gphotofs (as mentioned elsewhere on this page) solved my problem --- i just didn't see how to use it at first.

At least for my case, after installing gphotofs (which is available from the Synaptic Package Manager), all you have to do is create a "mount point", that is, a directory to mount the camera's internal filesystem on.

So the sequence is something like: mkdir tmp gphotofs tmp and then all the files, including autoprint.mrk, *.mov, *.jpg, appear in tmp, in a hierarchy as stored on the camera.

You can then copy them out or deal with it otherwise.

Thanks Matt for the thread, and everybody who posted to it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.