Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with offline installation of a package. For instance; python-qt4 module requires sip-api-8.1 but it is a virtual package, hence there is no .deb file to install. How can I fix this situation? I know that python-sip package provides it, but I am looking for a general solution.

$ apt-cache show python-qt4
Package: python-qt4
Priority: optional
Section: python
Installed-Size: 12103
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Architecture: i386
Version: 4.9.1-2ubuntu1
Replaces: python-qt4-dev (<< 4.4.4-3~)
Provides: python2.7-qt4
Depends: python2.7, python (>= 2.7.1-0ubuntu2), python (<< 2.8), libc6 (>= 2.3), libgcc1 (>= 1:4.1.1), libpython2.7 (>= 2.7), libqt4-dbus (>= 4:4.8.0-1~), libqt4-declarative (>= 4:4.8.0-1~), libqt4-designer (>= 4:4.8.0-1~), libqt4-help (>= 4:4.8.0-1~), libqt4-network (>= 4:4.8.0-1~), libqt4-script (>= 4:4.8.0-1~), libqt4-scripttools (>= 4:4.8.0-1~), libqt4-svg (>= 4:4.8.0-1~), libqt4-test (>= 4:4.8.0-1~), libqt4-xml (>= 4:4.8.0-1~), libqt4-xmlpatterns (>= 4:4.8.0-1~), libqtassistantclient4 (>= 4.6.3), libqtcore4 (>= 4:4.8.0-1~), libqtgui4 (>= 4:4.8.0-1~), libqtwebkit4 (>= 2.2~2011week36), libstdc++6 (>= 4.1.1), sip-api-8.1
Suggests: python-qt4-dbg

However:

$ apt-cache show sip-api-8.1
N: Can't select versions from package 'sip-api-8.1' as it is purely virtual

EDIT: How does this select python-sip instead of the original?

$ apt-get install -s sip-api-8.1
Reading state information... Done
Note, selecting 'python-sip' instead of 'sip-api-8.1'
share|improve this question

1 Answer 1

up vote 2 down vote accepted

Because python-sip provides sip-api-8.1:

$ apt-cache show python-sip | grep Provides
Provides: python2.7-sip, sip-api-8.0, sip-api-8.1

How can you find that out for yourself?

$ aptitude show sip-api-8.1
No current or candidate version found for sip-api-8.1
Package: sip-api-8.1
State: not a real package
Provided by: python-sip

or, using grep-dctrl in dctrl-tools:

$ grep-aptavail -F Provides -s Package,Provides sip-api-8.1
Package: python-sip
Provides: python2.7-sip, sip-api-8.0, sip-api-8.1
share|improve this answer
    
Nice approach, thanks! –  Mustafa Jul 23 '12 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.