Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Sabayon, Sabayon took over the boot process. I have reinstalled grub with

sudo grub-install /dev/sda

which I got from ubuntu wiki grub2

Sabayon is an lvm on sda8 and sda9 see below.

sayth@sayth-TravelMate-5740G[~]
[22:03]:fdisj -l
zsh: correct 'fdisj' to 'fdisk' [nyae]? y

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x104abfd7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    27265023    13631488   27  Hidden NTFS WinRE
/dev/sda2        27265024    27469823      102400    7  HPFS/NTFS/exFAT
/dev/sda3        27469824   786911894   379721035+   7  HPFS/NTFS/exFAT
/dev/sda4       786913218   976768064    94927423+   5  Extended
/dev/sda5       786913280   812302335    12694528   83  Linux
/dev/sda6       812304384   816254975     1975296   82  Linux swap / Solaris
/dev/sda7       816257024   871153663    27448320   83  Linux
/dev/sda8       871155712   872179711      512000   83  Linux
/dev/sda9       872181760   976766975    52292608   8e  Linux LVM

However when you update-grub2 it doesn't detect that Sabayon exists, how can I fix this?

Edit I also then tried to redo it using grub-customizer but it just doesn't seem to detect it.

2nd Edit: I think from reading around it doesn't like /dev/sda8 as its a boot partition for the lvm on sda9. It flat out will not recognise it.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Mount the lvm partitions an run the grub update

The most succinct way to enable the volume groups is

sudo vgchange -a y

Simply run update grub to locate the lvms into grub.

sudo update-grub2
share|improve this answer
    
This answer would be much improved, if you edit it to include detailed information about how to do these things. –  Eliah Kagan Aug 3 '12 at 19:58
    
Actually this is correct. However as I intially feared that the lvm was causing the grub2 detection error I reinstalled to a standard instal and as such this resolved my issue similar to what you describe. mount -t ext4 /dev/sda7 /mnt/ update-grub2 –  sayth Aug 5 '12 at 12:40
add comment

Try this:

 sudo update-grub2

This should update your grub2 cfg file.

share|improve this answer
    
that doesn't detect fedora , just win7 and Ubuntu . –  sayth Jul 23 '12 at 21:00
    
Have you got the image in the /boot folder of grub? –  TheBlueCat Jul 24 '12 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.