Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My myTouch Slide wasn't mounting, so I decided to open Disk Utility. My phone shows up but when I click "Mount" it gives me this error:

Error mounting: mount exited with exit code 1: helper failed with:
mount: according to mtab, /dev/sdb1 is already mounted on /
mount failed

Here's my mtab:

/dev/sdb1 / ext4 rw,errors=remount-ro,commit=0 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/matthew/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=matthew 0 0
/dev/sdg1 /media/Seagate\040GoFlex ext4 rw,nosuid,nodev,uhelper=udisks 0 0

EDIT: Here's my fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=3b0db205-2bdb-4c98-a506-6bdd3520d540 none            swap    sw              0       0
share|improve this question
    
It will be very helpful if you also provide your /etc/fstab file –  binW Dec 9 '10 at 6:35
add comment

2 Answers 2

You may want to make a specific entry for your phone in order to have it mount where you want it to mount. First, check what the UUID of the devices hooked up to your machine:

craig@lister:~$ sudo blkid
[sudo] password for craig: 
/dev/sdb1: UUID="[long-string-of-hex-here]" TYPE="ext4"
...

That'll show you what the various UUIDs are for the filesystems on your machine. Then, you can add the device explicitly:

UUID=[long-string-of-hex-here] /mnt/phone  (and the rest of the mount line)

This may make life a little easier for you if your phone isn't showing up where you think it is. It also may clarify why your machine is trying to re-mount /dev/sdb1 when you click on your phone.

Hope this helps!

share|improve this answer
    
Well, now it's happening to my external HDD. So, following your instructions, I should add: " UUID="33c920a3-617f-4259-b6f7-c8b76bb68d71" " to my mtab? –  RPG Master Dec 10 '10 at 7:12
    
I got that from what the terminal gave me: "/dev/sda1: LABEL="Seagate GoFlex" UUID="33c920a3-617f-4259-b6f7-c8b76bb68d71" TYPE="ext4" " –  RPG Master Dec 10 '10 at 7:13
    
That should be to the fstab, not mtab. –  CraigM Dec 10 '10 at 16:27
add comment

Error mounting: mount exited with exit code 1: helper failed with: mount: according to mtab, /dev/sdb1 is already mounted on / mount failed

Disk Utility reported error in Ubuntu 10.10 while mounting one of the drives

REASON

Your FSTAB file is incorrectly configured. Your /etc/mtab and /etc/fstab files must be showing difference in mounted volumes entries. which is confusing for the "Disk Utility" to figure out on its own.

Example

In my case reinstalling Ubuntu 10.10 with auto partition option created the problem, leaving my Data Drive(IDE HDD) /dev/sda unreadable. Ubuntu was installed at /dev/sdb (SATA HDD) but reported as /dev/sda in FSTAB, and I was unable to mount my 2nd HDD(Data Drive)

/etc/mtab contains the next line:

/dev/sdb1 / ext4 rw,errors=remount-ro,commit=0 0 0

Whereas '/etc/fstab' shows:

/dev/sda1 / ext4    errors=remount-ro 0       1

Solution

You can change it manually, by changing your / partition entry to it's actual device name.

Find your / partition's actual device (eg. in my case /dev/sdb1)

  1. Press ALT + F2 and run gksudo gedit.
  2. Open up /etc/fstab
  3. Change your root partition to the device listed in "Disk Utility".
  4. Restart your computer, and enjoy

In my case I changed the next line from /etc/fstab:

/dev/sda1 / ext4    errors=remount-ro 0 1

to

/dev/sdb1 / ext4    errors=remount-ro 0 1

Read about 'MTAB' & 'FSTAB' in wikipedia for more clarity... Quite nicely explained there...Thanks Ton 2 all you guys @ Wikipedia.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.