Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Because of skype sound issues I installed pavucontrol and I can change settings so the sounds work again with skype. I had to set both (recording&playback of skype) to "built-in Audio Analog Stereo" instead of "Monitor of built-in Audio Digital Stereo (HDMI)", I could only edit it when a skype call was in progress.
But unfortunately after a while not using skype the settings in the pavucontrol return to the default sink "Monitor of built-in Audio Digital Stereo (HDMI)", even though I press the lock sign in pavucontrol ...
How do I make the changes to pavucontrol permanent?
I use Skype 4.008 in Ubuntu 12.04 (AMD64).

Interestingly the "Monitor of built-in Audio Digital Stereo (HDMI)" does not show up in the "Sounds settings" of gnome-control, there is only one sink "Analog output - built-in Audio".

I've uploaded to Pastebin the output from pacmd list-sinks and pacmd list-modules.

share|improve this question

2 Answers 2

From the question and the audio settings posted in the pastes from the commands list-sinks, and list-modules there may be an issue with a pulseaudio module to restore an output device. Let me suggest further steps to narrow doen the issue:

Temporarily remove modules

We don not know if that helps but we may be able to narrow the issue down if we temporarily removed modules that are in question.

To remove a module issue the following in a terminal:

pacmd unload-module <index>

The present <index> will be listed from pacmd list-modules. Try to unload any single one of the following loaded modules (by index!) to test if it is the culprit:

  • module-suspend-on-idle (because your issue is associated on idle of Skype)
  • module-loopback (because you don't need the "Monitor of..." device)
  • module-switch-on-port-available (unlikely but worth a try)
  • module-intended-roles (switches to the intended device when a phone call comes in)

The default setting with loading of the default modules will be restored by running

pulseaudio -k

Check for errors

Also you may want to see if there are any errors from pulseaudio in the system log files before your HDMI sink is connected.

Remove user-space configuration

Sometimes we have erroneous configuration settings in the user-specific settings. To overcome this me may try if deleting ~/.pulse helps (it will be recreated on next start of pulseaudio)

mv ~/.pulse ~/.pulse.old
pulseaudio -k # to restart pulseaudio

Generate a pulseaudio log

Another approach would be to check for useful messages to narrow down the issue by generating a pulseaudio log file from running pulseaudio in verbous mode (see here on how to do this).

Let us know of the result to better point you to a permanent solution.

share|improve this answer
    
Thanks again for your help. I did not try your steps, sorry! I found a simple tweak in pavucontrol (see other answer), although it might be only a work-around and not addressing the real problem, it worked so far and I did not encounter any side-effect the past 6 months. –  Filbuntu Feb 13 '13 at 12:37
    
@Filbuntu: I believe by disabling HDMI-audio, and in case you do not need this, you will have a stable workaround here. Thanks for sharing this :) –  Takkat Feb 13 '13 at 12:44
up vote 2 down vote accepted

A simple configuration setting helped me so far (half a year) on Ubuntu LTS 12.04. In pavucontrol in the last tab "configuration", I have two "Built-in Audio" section where I can choose a profile. The first one had "Digital Stereo (HDMI) Output" as profile. I changed this to "Off" and I had the above described problem not anymore. Here is a screenshot:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.